No Search REsults

  • PMan

    PMan - 2012-05-18


    I have switched to mod_php and gotten to the point where there are no errors. But when I type any text or number into the search filed at the upper right, I get 0 results.  I can go to a collection with a bunch of files, and typ in the first letter, or the first word of a file, and I get 0 results.

    Would there be anything in /tmp/api.log that would indicate why I'm not getting any results? What would I look for?


  • Anonymous - 2012-05-19

    hi we might have the same problem are you using a guest account to search?if so the author gave me these bug fix
    DROP VIEW docmgr.dm_view_search;
    CREATE VIEW docmgr.dm_view_search AS
    SELECT,, dm_object.summary, dm_object.object_owner, dm_object.filesize, dm_object.last_modified, dm_index.idxfti
       FROM docmgr.dm_index
       LEFT JOIN docmgr.dm_object ON dm_index.object_id =;

  • Eric Lawman

    Eric Lawman - 2012-05-21

    What type of documents are you searching for?  Are these text files, office documents, or something else?  Also, you can see what DocMGR has indexed in the docmgr.dm_index table.  I have a feeling there's something happening when the indexer script tries to run.  You can test it by going to your root docmgr installation directory and running "php bin/docmgr-indexer.php -reindex-all".  This will reindex all documents in your DocMGR installation and you'll be able to see if any errors are being generated.


  • PMan

    PMan - 2012-05-28

    Problem solved!  Thanks again Eric.

    I had disabled user id#1 and was using a different user name/ID for the admin account. So bin/docmgr-indexer.php wouldn't run with the default ID #1. When I tried to run it from the command line, I got "the Account is Disabled". 

    I changed the default ID#, and now all is well.

  • jonesal2

    jonesal2 - 2013-02-22

    I am having the same problems too, here's the output fromthe CLI

     root@docmgr:/var/www/docmgr# php bin/docmgr-indexer.php --reindex-all
    PHP Warning:  include(header/ failed to open stream: No such file or directory in /var/www/docmgr/bin/docmgr-indexer.php on line 21
    PHP Warning:  include(): Failed opening 'header/' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/docmgr/bin/docmgr-indexer.php on line 21
    PHP Notice:  Use of undefined constant APP_PHP - assumed 'APP_PHP' in /var/www/docmgr/app/common-docmgr.php on line 152
    Error!  The application <b>APP_PHP</b> could not be found in /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games<br>
                      This application is required by DocMGR to run.<br><br>

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks