#18 Running does not change speed

v0.4
closed
Farrer
Engine (13)
5
2012-07-18
2010-02-04
No

Movement is extremely slow (and extremely annoying this way) please make running the player move faster.

Additionally there should be a [ ] always run option (which I recommend to turn on by default)

Discussion

  • Iwan Gabovitch (qubodup)

    Oh, I realized that I have to press right mouse button and move it away from my char. However the Shift+move run function only shows the run animation, but does not speed up running

     
  • Farrer

    Farrer - 2010-02-05

    About the "always run" option, it's already implemented on 0.4 (on main menu, Options -> Game). I've enabled it by default on the current dev version (was disabled by default on 0.4).

    About the shift+move it's working here (both dev or 0.4 version). Maybe we should increase the run speed?

     
  • Iwan Gabovitch (qubodup)

    Hm, well when I hold shift+give a move command, the run animation will play, but the speed will be as normal. If I press Shift while walking, the run animation will play as long as I hold it, but speed will remain normal.

    See this video http://www.youtube.com/watch?v=j__z7gl0JB0

     
  • Farrer

    Farrer - 2010-02-05

    Got it. The shift+move was implemented on keyboard move, but not on the A move (In fact, I never thought using it with the A)...
    It should be fixed on git now...

    Thanks for the report (and for the illustrative video)!

     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks