#43 Migration problems

closed
Data (12)
5
2008-01-11
2007-12-13
No

There appear to be some migration problems related to the use of Model code which is not tightly coupled to the migration versions. I did not record it but I tried creating the database and just migrating forward from scratch. I encountered several problems with some of the migrations (3 to 4) mostly where some of the Model code used to populate new columns refers to columns that don't exists at that migration version. This is not urgent but should probably be cleaned up. Sorry for not writing this down while I was doing it but it can be replicated by starting with an empty database and migrating it to current version

Discussion

  • chickmarkley

    chickmarkley - 2008-01-03
    • status: open --> closed-fixed
     
  • chickmarkley

    chickmarkley - 2008-01-03
    • status: closed-fixed --> open
     
  • chickmarkley

    chickmarkley - 2008-01-03

    Logged In: YES
    user_id=1814905
    Originator: YES

    Inadvertantly closed by chick, re-opened

     
  • Thomas G. Habing

    Logged In: YES
    user_id=470665
    Originator: NO

    I've fixed one problem wherein the title_sort column was not being updated during migration 10, but this was not fatal error. I've also tested the complete set of migrations starting with an empty db, and I can migrate all the way up to 15 and back down to zero without a problem. I think this is fixed; although, I was not able to recreate any problems when going from 3 to 4 as described above.

     
  • Thomas G. Habing

    • status: open --> pending
     
  • chickmarkley

    chickmarkley - 2008-01-11

    Logged In: YES
    user_id=1814905
    Originator: YES

    Good enough for me

     
  • chickmarkley

    chickmarkley - 2008-01-11
    • status: pending --> closed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks