Hello,

I am new to dkim. Following the instructions inside a how-to I came to an early point where I could not figure out how to continue. During build I get this error msg:

dkim-keys.c:(.text+0x3b9): undefined reference to `__dn_expand'
dkim-keys.c:(.text+0x3c4): undefined reference to `__dn_skipname'
dkim-keys.c:(.text+0x604): undefined reference to `__dn_expand'
dkim-keys.c:(.text+0x634): undefined reference to `__dn_expand'
/home/andy/dkim-milter-2.8.2/obj.Linux.2.6.22.19-0.1-default.x86_64/libdkim/libdkim.a(dkim-policy.o): In function `dkim_get_policy_dns':
dkim-policy.c:(.text+0x4d7): undefined reference to `__dn_expand'
dkim-policy.c:(.text+0x4e2): undefined reference to `__dn_skipname'
dkim-policy.c:(.text+0x703): undefined reference to `__dn_expand'
dkim-policy.c:(.text+0x751): undefined reference to `__dn_expand'
/home/andy/dkim-milter-2.8.2/obj.Linux.2.6.22.19-0.1-default.x86_64/libdkim/libdkim.a(dkim-test.o): In function `dkim_test_dns_get':
dkim-test.c:(.text+0x7a2): undefined reference to `__dn_comp'
dkim-test.c:(.text+0x85b): undefined reference to `__dn_comp'
dkim-test.c:(.text+0x9d1): undefined reference to `__dn_comp'
/home/andy/dkim-milter-2.8.2/obj.Linux.2.6.22.19-0.1-default.x86_64/libdkim/libdkim.a(util.o): In function `dkim_check_dns_reply':
util.c:(.text+0xf3): undefined reference to `__dn_expand'
util.c:(.text+0xfe): undefined reference to `__dn_skipname'
util.c:(.text+0x1bb): undefined reference to `__dn_expand'
util.c:(.text+0x1f0): undefined reference to `__dn_expand'
/home/andy/dkim-milter-2.8.2/obj.Linux.2.6.22.19-0.1-default.x86_64/libar/libar.a(ar.o): In function `ar_sendquery':
ar.c:(.text+0x157a): undefined reference to `__res_nmkquery'
/home/andy/dkim-milter-2.8.2/obj.Linux.2.6.22.19-0.1-default.x86_64/libar/libar.a(ar.o): In function `ar_dispatcher':
ar.c:(.text+0x1b6e): undefined reference to `__dn_skipname'
ar.c:(.text+0x1b90): undefined reference to `__dn_skipname'
ar.c:(.text+0x213b): undefined reference to `__dn_expand'
collect2: ld returned 1 exit status
make[1]: *** [dkim-filter] Error 1
make[1]: Leaving directory `/home/andy/dkim-milter-2.8.2/obj.Linux.2.6.22.19-0.1-default.x86_64/dkim-filter'
make: *** [all] Error 2
h1385633:/home/sw/dkim-milter-2.8.2 #


Am I missing a library? I did point on my suse 10.3 x64 system to the lib64 path inside devtools/Site/site.config.m4

Any help is greatly apreciated!

Thank you in advance.

Johannes