djmount 0.71 and Mediatomb

  • jpichlbauer

    jpichlbauer - 2008-05-17

    Hi folks,

    I'm trying to get my dreambox running Gemini Project image 4.0.0 to play transcoded DivX files, but djmount on the Dreambox doesn't display the transcoded video items :(
    Here's the configuration of my dreamboxe's djmount:
    djmount (djmount) 0.71
    Copyright (C) 2005 Rémi Turboult
    Compiled against: FUSE 2.4, libupnp 1.6.0

    I have added an MPEG1 file to mediatomb's video share, and this is the only file which i can see:
    root@dm600pvr:/media/Upnp/juepis MediaTomb/Video> ls -l
    -r--r--r--    1 root     root      3462935 Jan  1  2000 Selbstmord.mpg
    root@dm600pvr:/media/Upnp/juepis MediaTomb/Video>

    although, in the .metadata directory, all available video items from MediaTomb are shown:
    root@dm600pvr:/media/Upnp/juepis MediaTomb/Video> ls -l .metadata/
    -r--r--r--    1 root     root          604 Jan  1  2000 Battlestar.Galactica.S04E01.HDTV.XviD-LOL.avi.xml
    -r--r--r--    1 root     root          601 Jan  1  2000 Battlestar.Galactica.S04E02.HDTV.XviD-LOL.avi.xml
    -r--r--r--    1 root     root          623 Jan  1  2000 Battlestar.Galactica.S04E03.The.Ties.That.Bind.HDTV.XviD-FQM.avi.xml
    -r--r--r--    1 root     root          620 Jan  1  2000 Battlestar.Galactica.S04E04.Escape.Velocity.HDTV.XviD-FQM.avi.xml
    -r--r--r--    1 root     root          628 Jan  1  2000 Battlestar.Galactica.S04E05.The.Road.Less.Travelled.HDTV.XviD-FQM.avi.xml
    -r--r--r--    1 root     root          612 Jan  1  2000 Battlestar.Galactica.S04E06.READNFO.HDTV.XviD-0TV.avi.xml
    -r--r--r--    1 root     root          478 Jan  1  2000 Selbstmord.mpg.xml
    -r--r--r--    1 root     root          576 Jan  1  2000 nice2seeyou.avi.xml
    root@dm600pvr:/media/Upnp/juepis MediaTomb/Video>

    I can see no obvious difference between the "Selbstmord.mpg.xml" and i.e. the "nice2seeyou.avi.xml":

    root@dm600pvr:/media/Upnp/juepis MediaTomb/Video> cat .metadata/nice2seeyou.avi.xml
    <?xml version="1.0" encoding="UTF-8"?>
    <item id="261" parentID="6" restricted="1">
    <res protocolInfo="http-get:*:video/mpeg:*">;res_id=none&amp;pr_name=vlcprof&amp;tr=1&amp;ext=.mpg</res>
    <res protocolInfo="http-get:*:video/x-msvideo:*" size="52127744" bitrate="1218" resolution="496x368" sampleFrequency="48000" nrAudioChannels="1">;res_id=0&amp;ext=.avi</res>
    root@dm600pvr:/media/Upnp/juepis MediaTomb/Video>

    Compared to the "Selbstmord.mpg.xml" where i can see the video:
    root@dm600pvr:/media/Upnp/juepis MediaTomb/Video> cat .metadata/Selbstmord.mpg.xml
    <?xml version="1.0" encoding="UTF-8"?>
    <item id="9" parentID="6" restricted="1">
    <upnp:artist>RTL - Newmedia</upnp:artist>
    <res protocolInfo="http-get:*:video/mpeg:*" size="3462935" bitrate="309" sampleFrequency="32000" resolution="320x240" nrAudioChannels="1">;res_id=0&amp;ext=.mpg</res>
    root@dm600pvr:/media/Upnp/juepis MediaTomb/Video>

    I've also tried to debug Upnp with Cidero, but the Cidero Upnp client shows all files as expected, and through VLC player, i can also stream the transcoded AVI source from mediatomb..
    All hints highly appreciated, thanks for your help in advance!


    • jpichlbauer

      jpichlbauer - 2008-05-17

      Sorry, there is actually one obvious difference: the transcoded protocolInfo tags do not show the video length, resolution etc. infos, can this be the cause?


    • bluesmoke

      bluesmoke - 2008-10-28

      Hi, I am using djmount on ubuntu. Djmount is highly suitable for me bcaz it allow me to play media files in my favorite player But I am having a problem with it. It display my media server (MeadiaTomb) but some time it (mediatomb) disappears from the mounted directory. (Although it looks quite stable in other media players like XBMC). It used to appear again but I want to know that why it is doing so.......


    • Arvy

      Arvy - 2008-11-19

      Hi Juergen,

      I have a question for you (sorry that I can't give you an answer to your question, haven't tried that out).

      How does djmount perform on your dreambox, regarding cpu and memory usage?

      I created a client for the relook400s, but it performs very very bad, takes up to 40MB of memory and while browsing will use up 80-90% of cpu capacity. Browsing the tree for the first time takes up to 1 minute before it shows anything.

      Thanks for your reply



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks