Migrate from GitHub to SourceForge with this tool. Check out all of SourceForge's recent improvements.
Close

#5 A/C is not shut off when needed

closed-fixed
9
2003-12-28
2002-07-28
No

Balancing controller fails to shut off the HVAC unit
under some circumstances

Discussion

  • Vadim Tkachenko

    Vadim Tkachenko - 2002-07-28
    • priority: 5 --> 8
    • assigned_to: nobody --> vtt
     
  • Vadim Tkachenko

    Vadim Tkachenko - 2002-07-28

    Logged In: YES
    user_id=16279

    A/C is not shut off when all the zones are disabled

     
  • Vadim Tkachenko

    Vadim Tkachenko - 2002-07-28
    • status: open --> closed-fixed
     
  • Vadim Tkachenko

    Vadim Tkachenko - 2002-07-28

    Logged In: YES
    user_id=16279

    Zone status (whether enabled and/or voting) wasn't being
    checked when calculating the total demand. Fixed.

     
  • Vadim Tkachenko

    Vadim Tkachenko - 2002-08-29

    Logged In: YES
    user_id=16279

    Damn, I thought I fixed it. The A/C is not shut off when all
    the zones are disabled.

     
  • Vadim Tkachenko

    Vadim Tkachenko - 2002-08-29
    • priority: 8 --> 9
    • status: closed-fixed --> open-accepted
     
  • Vadim Tkachenko

    Vadim Tkachenko - 2002-09-02

    Logged In: YES
    user_id=16279

    A/C is not shut off if the remaining zones have a positive
    demand, but it is on the rising and didn't reach the zone
    controller trigger point yet.

    When the setpoint is changed in such a way that the demand
    is higher than the trigger point, and then the zone is
    disabled, the A/C shuts off OK.

     
  • Vadim Tkachenko

    Vadim Tkachenko - 2003-05-08
    • labels: --> Control Logic
     
  • Vadim Tkachenko

    Vadim Tkachenko - 2003-05-09
    • milestone: --> Production Showstopper
     
  • Vadim Tkachenko

    Vadim Tkachenko - 2003-12-27

    Logged In: YES
    user_id=16279

    Clarification: the symptoms described earlier were pertinent
    to balancing controller only. It seems that this controller
    is very reluctant to lower the calculated demand value even
    if all the zones are disabled. It may be a good idea to
    expire the temperature readings in the
    AbstractZoneController itself - right now it seems that the
    last calculated demand value is just stuck there forever.

     
  • Vadim Tkachenko

    Vadim Tkachenko - 2003-12-28
    • status: open-accepted --> closed-fixed
     
  • Vadim Tkachenko

    Vadim Tkachenko - 2003-12-28

    Logged In: YES
    user_id=16279

    This bug seems to be related to bug #866442, as well as some
    others. Indeed, it takes forever for demand to go down to
    zero if it is already low, even if the zone temperatures are
    lower than setpoints, but more than setpoint minus "happy"
    offset. In this case, the demand drop is caused by P
    components rising to offset the demand and eventually
    reaching the threshold, which causes HVAC to stop.

    Hope that this bug is gone for good now.

     

Log in to post a comment.