Andreas Zita - 2013-01-31

VideoInfoHeader2.InterlaceFlags is always equal to Unused | FieldPatBothRegular even though the image clearly is interlaced. I get this header by marshalling AMMediaType.formatPtr to VideoInfoHeader2 and I get the MediaType that has the most lines (out of two available). No matter what channel I run on my TV-source it is always telling me the image is not interlaced. And if I set the SampleFormat to interlaced anyway, no difference. IVMRDeinterlaceControl9 returns 4 modes and I have tried all, no difference. Please help me understand this =).

Update:

I have found out that I can (should?) change the properties in the VideoInfoHeader2, set interlacing to for instance interlaced and weave and then marshall it back to mediatype and set it as format on streamConfig. I felt confident this was going to solve the problem. But it did not.

When getting the mediatype back again after updating it, it is back at the previous value again which is weird because the SetFormat-call does not return any error. What am I missing here?

 
Last edit: Andreas Zita 2013-01-31