Make fails for Dirac 1.0.2! Need help!

2012-02-13
2013-06-04
  • Marshall West

    Marshall West - 2012-02-13

    I'm trying to install Dirac 1.0.2 and when I run the "make" command I get this error:
    parseunit_byteio.cpp: In member function ‘bool dirac::ParseUnitByteIO::IsValid()’:
    parseunit_byteio.cpp:127:23: error: variable ‘next_parse_code’ set but not used
    parseunit_byteio.cpp:131:13: error: variable ‘next_unit_next_parse_offset’ set but not used
    cc1plus: all warnings being treated as errors

    Any ideas? Any help would be much appreciated.

     
  • Anuradha Suraparaju

    Hi,

    The easiest thing to do would be to edit parseunit_byteio.cpp and delete the lines causing the error. This shouldn't affect the functionality as the variables are not being used.
    The Dirac research implementation is no longer being actively maintained. It has been replaced with Schroedinger (http://diracvideo.org/) and is a faster and more representative implementation of the Dirac specification.

    Regards,
    Anu

     
  • Anuradha Suraparaju

    A typo in the previous reply. Meant Schroedinger is a faster and a more complete implementation of the Dirac spec.

     

Log in to post a comment.