smtp://userid%40jdoe.net@smtp.mail.com fails

2006-09-17
2013-05-01
  • Startups.in

    Startups.in - 2006-09-17

    Seems that if the username is of the form "userid@jdoe.net" instead of just "userid", then the invite session would fail.
    Also, note that the smtp.mail.com mandates the use of TLS but there doesn't seem to be a provision to set it in dimdim.

    INFO   | jvm 1    | 2006/09/17 01:50:18 | com.sun.mail.smtp.SMTPSendFailedException: 530 5.7.0 Must issue a STARTTLS command first b43sm8753567pyb
    INFO   | jvm 1    | 2006/09/17 01:50:18 |
    INFO   | jvm 1    | 2006/09/17 01:50:18 |     at com.sun.mail.smtp.SMTPTransport.issueSendCommand(SMTPTransport.java:1333)
    INFO   | jvm 1    | 2006/09/17 01:50:18 |     at com.sun.mail.smtp.SMTPTransport.mailFrom(SMTPTransport.java:906)
    INFO   | jvm 1    | 2006/09/17 01:50:18 |     at com.sun.mail.smtp.SMTPTransport.sendMessage(SMTPTransport.java:535)
    INFO   | jvm 1    | 2006/09/17 01:50:18 |     at com.dimdim.conference.application.email.Mailer2.sendMessage(Mailer2.java:353)
    INFO   | jvm 1    | 2006/09/17 01:50:18 |     at com.dimdim.conference.application.email.EmailDispatchWorker2.sendEmail(EmailDispatchWorker2.java:115)
    INFO   | jvm 1    | 2006/09/17 01:50:18 |     at com.dimdim.conference.application.email.EmailDispatchWorker2.run(EmailDispatchWorker2.java:84)
    INFO   | jvm 1    | 2006/09/17 01:50:18 |     at java.lang.Thread.run(Unknown Source)
    INFO   | jvm 1    | 2006/09/17 01:50:18 | a:[COULDNT_SEND_MESSAGE]
    INFO   | jvm 1    | 2006/09/17 01:50:18 | b:null
    INFO   | jvm 1    | 2006/09/17 01:50:18 | a:[VALID_UNSENT_ADDRESSES]

     
    • Nobody/Anonymous

      Hello

      Thanks for point out the issues with send invite functionality. We will try and reproduce the issues in our labs and would address them as we are able to reproduce them.

      Regards,
      Prakash

       
    • Startups.in

      Startups.in - 2006-09-17

      Not a problem, Prakash. I think the mandatory TLS required by SMTP server is what is causing the problem.

      com.sun.mail.smtp.SMTPSendFailedException: 530 5.7.0 Must issue a STARTTLS command first

       
    • Startups.in

      Startups.in - 2006-09-17

      Just to clarify, I realized that it is not the "userid" format bit the TLS that was causing the failure.

       
    • prakash.khot

      prakash.khot - 2006-09-19

      Thanks for your clarification. We will look into supporting SMTP server configurations that mandates TLS.

      Regards,
      Prakash

       

Log in to post a comment.