Unable to sharing application and desktop

  • Walker Cosmos

    Walker Cosmos - 2008-02-26

    Fresh installation CentOS 4.5 under VMWare workstation 6.

    After server started, I can access http://server/dimdim/ successfully, and "start meeting" works great.

    After create a new meeting, audio functionality works well.

    But if I try to start a application sharing or desktop sharing, I got "Image processing error" message, audio panel shows "connection timeout", and I found port 40001 and port 1935 cannot be connected. Then I found Streaming server and Media Server processes no longer exists (crashed).

    No noticeable log found in ConferenceServer/wrapper.log and MediaServer/www/logs, but StreamingServer/dimdimStreamingServer-1428997885-0.log contains:

    1429154066 - <info> - [dSS] - Connection::createPublisher(b5dc74f40a7f0e6685f31967.nc4z3kc.D) - BEGINS!
    1429154066 - <info> - [dSS] - Connection::createPublisher(b5dc74f40a7f0e6685f31967.nc4z3kc.D) - lookin gup topic ...!
    1429154066 - <info> - [dSS] - TopicManager::newTopic = [b5dc74f40a7f0e6685f31967.nc4z3kc.D] Going to acquire lock ....[1]
    1429154066 - <info> - [dSS] - TopicManager::newTopic = [b5dc74f40a7f0e6685f31967.nc4z3kc.D] BEGINS!!!
    1429154066 - <info> - [dSS] - TopicManager::deleteTopic(b5dc74f40a7f0e6685f31967.nc4z3kc.D) BEGINS - Topic Count : 1
    1429154066 - <info> - [dSS] - TopicManager::deleteTopic(b5dc74f40a7f0e6685f31967.nc4z3kc.D) FINISHED - Topic Count : 1
    1429154066 - <info> - [dSS] - TopicManager::newTopic - adding new topic [b5dc74f40a7f0e6685f31967.nc4z3kc.D][Topic Count=1]
    1429154066 - <info> - [dSS] - TopicManager::newTopic - Registering topic (b5dc74f40a7f0e6685f31967.nc4z3kc.D)...
    1429154066 - <info> - [dSS] - Topic [b5dc74f40a7f0e6685f31967.nc4z3kc.D] is being activated!!!
    1429154066 - <info> - [dSS] - TopicManager::newTopic - added new topic [b5dc74f40a7f0e6685f31967.nc4z3kc.D][Topic Count=2]
    1429154067 - <info> - [dSS] - TopicManager::newTopic = [b5dc74f40a7f0e6685f31967.nc4z3kc.D] ENDS!!!
    1429154067 - <info> - [dSS] - Connection::createPublisher(b5dc74f40a7f0e6685f31967.nc4z3kc.D) - got topic!
    1429154067 - <info> - [dSS] - Connection::createPublisher(b5dc74f40a7f0e6685f31967.nc4z3kc.D) - set role to publisher!
    1429154067 - <info> - [dSS] - ConnectionHandler::setWriteQueueMaxAge - setting [conn-RTMP-<unknown>-12557] to [5000] ms!
    1429154067 - <info> - [dSS] - XXXX Publish Successful : Stream (b5dc74f40a7f0e6685f31967.nc4z3kc.D) and Mode (live)
    1429154067 - <info> - [dSS] - SimplePacketHandler::onInvokePacket(publish) - ENDS
    1429154605 - <warning> - [dSS] - Failed to parse pending pdu data of length : 1443 bytes!<89>E¤<3>ú^Bt^Eéå

    Seems "PDU" data crashs server.

    I had noticed others had same problem also.

    Any suggestion?


    • gilly05

      gilly05 - 2008-02-28

      I am having a similar issue.  I have found that I get the error when I try to share the desktop.  If I try to share an application first, I can do that (I have shared notepad successfully thus far).  But, once I try to share the desktop, I get the "Iage Processing Error," and then I cannot share any application or the white board.  I also checked open ports after the error and found that 40001 is no longer listening.

      If I am not mistaken, the streaming server listens on 40001.  This tells me that attempting to shar a desktop causes the streaming server to stop.  If I do a "perl dimdimstartall.pl" it shows that port 80 is already in use (ok... so the conference server is still up), but it doesn't error on either the media server or the streaming server.  Plus, following that command, I can share apps again.  Still no desktop.

      This is on a clean CentOS 4.5 install using the online installation.  On the client side, I am using IE7 on Server 2003.  I have not yet tried it from a FF or IE6 system.

      I will try that and repost.  Any and all help on this would be greatly appreciated.  I would realy love to release this to my users.

      As an aside, I am also required to access the server via http://serverip:40000/dimdim.  I would like to be able to access it over port 80.  Any idea why that is?


    • gilly05

      gilly05 - 2008-02-28

      Ok... just tried on IE6 and same issue.  I figured it wouldn't make a difference, but I thought I'd check it ot anyhow.

      Anybody know what is going on here?

    • Ashish Talati

      Ashish Talati - 2008-03-03

      I am also running into same issue on VMWare Centos 4.5 Image.  Any update - Raj?

    • John

      John - 2008-08-28

      I have the same problem. I was working with Raj on another matter, 503 error, and got that working. Did a server reboot to make sure all would still work and not I am unable to share desktop or upload, ppt or pdf and the test audio video seems to be recording but doesn't play back anything.

      Maybe they are all part of the same problem?

      I can get an audio stream, share whiteboard and PM and chat haven't tried video and audio yet, and intermittently this feature cannot establish a stream.

      I also have an issue with zdaemon. I use the command found in another post in this forum and then check status and it says it is running but then check again and it dies.

      So I have multiple issues and I am not sure if they are all related.

      I am using native 3.5 tarball on RH FC7.

      This happens every time.

      Please let me know what files/logs are needed.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks