dimdim presentation on Internet : port again

  • Nobody/Anonymous

    hi, i wrote a first post : "authentication with CHECK_KEY : little probl" a few weeks ago but was not resolve. I don't have tried yet with this new release.. i will and let a com..
    But i need another help with dimdim communication with internet.
    Well, i explain :
    - i'm trying dimdim in lan for the job and it work perfectly (the new version works greater...)
    But we need dimdim for presentation with people from another companies, so they aren't in lan.
    So, on the firewall of our company, i open first : port 80 (tcp).
    But share of applications or desktop or other share wasn't working.
    So i tryed opening port 1935 (tcp) but it wasn't working too.
    When i start a share, the participants have on their screen : "connecting", then "timed out".

    On my server dimdim (debian etch), i put on the firewall (iptables) accepting only request on port 80 (tcp), 1935 (tcp) and it's working perfectly for the lan. So i don't understand.
    If anybody success with dimdim presentation on internet (i think so), an help is welcomed.

    Thanks to the dimdim team for their great job !

    Nicolas V.

    • Rajesh Dharmalingam

      Hello Nicolas,

      Thanks for the follow up.
      Could you please check if the firewall is enabled on the presenter machine from where you are trying to access the conference server.

      Also, could you please let us know what output you are getting for the following from the machine you are trying to start the conference.

      c:\telnet <dimdimServerAddress> <dimdimPortNumber>


      • Nobody/Anonymous

        Hello Rjesh and Nicolas,

        just to let you know that I'm facing the same issue. Same ports opened, all is verified, same time out when sharing.

        The thing is that there are no problem in the lan, only outside and the tests are with the same machine to start the conference.

        telnets from the guests works well against the dimdim server.

        Thank you in advance for the help.

    • Nobody/Anonymous

      Hello Rajesh

      well, the computer from where i start the conference has the firewall turned off and is in my LAN;
      and the telnet don't give me lot of informations, i explain :
      it connect in telnet, but i stay on the blank page without possibilities of writing or escaping with "ctrl+c" combination. So i escape with the 'red croix'.
      I thank you for trying resolving the issues.

      I add some information about my configuration :

      the server is in my LAN.
      In my lan (presenter and attendee),all is working : sharing applications ... ( i dont tryed audio nor video sharing)

      I associated an IP public with my dimdim server for attendees access to my server.
      I opened port 80 and 1935 (both tcp) on the firewall of the companies.
      The server (dimdim) has the firewall turned off.
      The attendees on internet can access to the dimdim server entering in their browser "http://X.X.X.X" where X.X.X.X is the public address, tchat is working but as you know the sharing application  result in a "timed out".

      Nicolas V.

    • Rajesh Dharmalingam

      Hello Nicolas,

      Sorry for the delayed response and thanks for the follow up. Could you please try the same experiment of telne from the machine you are trying to access now as i have mentioned above and provide me the details.

      Also, could you please send me the wrapper.log to rajesh(@)dimdim.com.


    • dimdim_uday

      dimdim_uday - 2007-07-26

      Could you please let us know if your problem is solved?

    • Nobody/Anonymous

      so you are using debian, maybe you can close your unused java application.  sometime other java program is conflict with dimdim java application.
      1. stop dimdim
      2. $ top
      it will show the runing application. if there is java, maybe you can try to shutdown it.
      3. $ kill -kill [PID]
      4. start dimdim
      then try again

      shanghai, china

    • Nobody/Anonymous

      thks at all; No, my problem is not solved again, i have had to stop my test for a while, but i will try later and give feedback, sorry for the late, will post soon !

      Nicolas V


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks