Error Sharing PPT or PDF

  • Justin

    Justin - 2008-10-17

    I'm having a problem uploading PDF or PPT files.  I installed the Dimdim_Linux_Native_Install_v3.5 on a clean CentOS 5.0 system.  I followed all of the instructions in the read me file for the install.  I have the following installed:

    Libc 2.5
    JRE 1.6.0_10
    JDK 1.6.0_7
    Lighttpd 1.4.20
    OpenOffice 2.3 (I can't get 2.4 right now.  They are only offering 3.0 because of the current download demand)
    CherryPy 3.0.1
    Flup 0.5 (the readme says v1, but the instructions below it show 0.5.  I have tried it with both)
    zdaemon 2.0.2

    Everything was installed as root.

    I am able to connect, start a meeting, share the desktop or whiteboard, but every powerpoint or pdf gives the same error "The document conversion failed with error: document id generation failed."  This happens with every PPT or PDF, not just one in particular. 

    I checked the forums, and I see that other people have had this issue, but I don't see any resolution.  A couple pf people said it just started working, and one person said he had CherryPy 3.1 and switched to 3.0.1, and then it worked.  I naturally tried both, but had the same result.  I also did a clean install of the OS, and all of the components listed above, and still have the same issue.  I'm sure there must be something small I am overlooking.

    Has anyone found a resolution to this problem?

    Thanks in advance for any help or sugestions.

    • soulsurfer

      soulsurfer - 2009-01-29

      We are also unable to upload ppt and pdf docs on the open source version.  works fine on the web...

    • Lhoste

      Lhoste - 2009-02-01


      I had the same problem recently,
      I didn't succeed in converting few ppt and pdf documents.
      To succeed I saved my documents in pptx with the pack office 2007.
      After that, conversion with dimdim was ok.

      Best regards,


    • Jim Livingston

      Jim Livingston - 2009-02-24

      Is this the Opensource version or one of the commerical versions? I have the Linux 4.5 on Centos 5.3, Opensource version running and neither the URL sharing nor the PDF/PPT document sharing work. I noticed that the guide book for the commercial versions shows buttons on the preferences tab to enable or disable these features. Did you ever resolve your upload issues?


    • shaneel :)

      shaneel :) - 2009-03-27

      Have you imported the required modules in python? if its correct then you neet to check whether the Media Server component is running or not.
      Might be a reason that the environment path is not correctly configured.What is there in LD_LIBRARY_PATH ? have you entered open office path in that ?


Log in to post a comment.