Can only access server inside firewall

Zach Cox
  • Zach Cox

    Zach Cox - 2006-10-19

    First off, let me say that DimDim is sweet!  You guys have created something really great here, especially open sourcing it.  I like it much better than Webex.

    I have a home network behind a Linksys WRT54G wireless router (on cable modem).  I installed DimDim alpha on an Ubuntu 6.06 server with local IP address and port 9090.  I put these parameters in server.xml as per instructions.

    I registered my router's IP address with and got a dynamic url (let's call it  So I put and port 9090 into as per instructions.  Also I setup my router to forward TCP traffic on port 9090 to

    I have two other Windows XP machines inside this network, and I can successfully login to DimDim at, both to host a conference and join a conference (btw, please let Firefox host conferences soon!)

    It seems though that machines outside my home network cannot get to  I work from home & had a coworker at our office try it, and he got an error message that said the page cannot be displayed

    I also have apache on the Ubuntu server (port 80) and machines outside my home network *can* successfully see pages at served by apache.

    Any ideas why DimDim is not accessible outside my network?  I can provide any other information as needed to diagnose.

    • Rohit Shankar (DimDim Inc.)


      Thanks for using Dimdim and your encouraging words.

      We have Dimdim running on similar set ups except for using We will try to replicate this scenario.

      Meanwhile I would suggest you to verify the setting once again. Also check if this is something related to firewall settings.

      Did you face similar issue with your other servers.


    • prakash.khot

      prakash.khot - 2006-10-20


      In case you have not already tried it; could you please try the following

      Have your co-worker telnet into this machine as follows

      telnet 9090

      Does it go through or does it say connection timed out?

      Please let me know.


      • Zach Cox

        Zach Cox - 2006-10-20

        Prakash - I had my coworker try to telnet, here's the error message he got:

        Could not open connection to the host, on port 9090: Connect failed

        When I try the telnet command from a machine inside the network (that can connect to DimDim) it says "Connecting to" then that disappears and I get a blank command line.


    • Clarence

      Clarence - 2006-10-24


      I am having firewall issues too.  I have to turn off the firewalls on both my XP machine (where Dimdim is installed) and my Win 2000 machine.  I have tried to open ports, etc but I can't get Dimdim past the firewalls.  It works great if I turn off both firewalls.  When I run Dimdim, I would expect the firewalls to see it and prompt me to allow it to run.  However, in my case, the firewalls just block the traffic and do not prompt me to open the ports, etc.  I have opened the ports manually but I must be missing something.



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks