Win32 3.0beta server - unable to connect

2008-01-10
2013-05-01
  • Nobody/Anonymous

    I have 1.60alpha running on my Windows XP computer and have no problem connecting to it from Windows and Linux boxes on my network (although Video isn't working, just Audio).  My problem is with 3.0.0Beta.

    I actually tried 3.0.0Beta before trying 1.60Alpha.  3.0.0Beta seemed to install correctly and lighttp was running, but I was unable to connect to dimdim by start menu link or pointing directly to http://<ip>/dimdim/.  I tried both IE and Firefox.  The only differences I could see between 1.60Alpha and 3.0.0Beta were that 1.60Alpha recognized that I had JRE6.0r3 installed while 3.0.0Beta made no mention of having or using JRE.  Also 3.0.0Beta installed lighhtp while 1.60Alpha didn't.

    I tried installing 3.0.0Beta 4 times before giving up and going with 1.60Alpha which worked perfectly on the first try.  Any ideas on what I may have done wrong while trying to get 3.0.0Beta running?

     
    • Nobody/Anonymous

      I have exactly the same problem. Did you find any solution?

       
      • Nobody/Anonymous

        No, I did not find a solution.  We were able to get the Windows version working on a copy of Windows Server 2008 beta on a different computer so I assume it will work under certain conditions.  We then tried it on a CentOS 4.5 machine, but it would crash every few minutes, so we are going with WebEx for the time being.

         
        • Nobody/Anonymous

          OK, scratch that idea.  WebEx is $375/mth, we're not paying that for the limited about of use it would get.  I was sent a DimDim beta invite so we will try that next.

           
    • Nobody/Anonymous

      Had similar problems - installed 3.0.0Beta on a Windows 2003 box, and it starts up fine in IE7 on the box on which it's installed, but won't connect from any other PC on the network... going to give 1.6Aplha a try now...

       
    • merc4a2

      merc4a2 - 2008-01-29

      I've had a similar issue.  From within my private LAN, I can access http://<localip>/dimdim/   but I have a firewall NATed to the internal IP and if I hit the external IP or hostname in the browser, I get a 400:bad request error.  I can successfully access the server if I leave off the /dimdim/ extension, so I know it's not a problem with the router, it must be expecting the local configured IP address, but I can't figure out how to make it work with the external IP.

      Mike

       
    • Carlos Vazquez

      Carlos Vazquez - 2008-01-31

      Yea, I'm rather frustrated for the same reason, I'm anxious to play with the software and using it right away.  Wish they'd send me an invite.  Is the Linux download specifically for CentOS?  I'm running Ubuntu and can't find a package for installation in adept.

       
      • DD Ganguly

        DD Ganguly - 2008-01-31

        sgtapi:

        Please send me your email address and I will ensure that you get an invite.

        dd@dimdim.com

         
        • Nobody/Anonymous

          DD,
          Can you please confirm whether the current Win32 3.0beta will only work for intranet (private IPs only)?  It seems to be the case with all these posts.

          Thanks,
          Tuan.

           
          • dimdim_uday

            dimdim_uday - 2008-02-06

            Hello Tuan,
            It is possible to run the win32 beta on the internet.
            However the NAT needs to be setup correctly.

            There are 3 functional servers in the Dimdim Meeting Server:-
            1) dimdim conference server
                Consists of a tomcat server running behind a lighttpd server
            2) dimdim streaming server
            3) dimdim Media Server
                Consists of cherrypy running behind a lighttpd server.

            It is possible to configure all these servers to work on the internet. The server.xml for the Tomcat server needs to be correctly set. In addition, the dimdim.properties file needs to be updated to ensure the correct join url is shown to the meeting participants.

            For DSS, the DssService.cfg needs to be configured with the correct bind IP address.
            For lighttpd - the lighttpd.conf needs to be set with the correct IP address.

            Regards,
            Uday

             
    • Nobody/Anonymous

      Would these issues keep the streaming server from running?  I can't get my streaming service to even start on Win2K server, the other two services work fine and I can access the server.

      thanks
      David

       
    • Nobody/Anonymous

      Does anyone has any instructions on how to make this possible on the Internet using Windows?  I am not that familiar with the Linux and would love to have this accessible especially using DynDns.

      Also, are there any threads that I can refer to for the configuration settings, e.g. how to give Mic to more people etc.

      Thanks.

       
    • Nobody/Anonymous

      I have a similar problem running Windows 3.0 beta. After a "flawless" install without any error message, the StartConf or JoinConf.htm doesnt work. seems like the webserver are not running - even though I've done the "startdimdim.bat" process.

      I'm running it on WinXP

       
    • Nobody/Anonymous

      I've had a similar issue, within the lan every, thing works fine.
      I´ve a wireless lan router and there seems to be no way to invite others from the internet.

      the router shows a ip adress to the internet and the maschines have static ip`s.

      has someone the same problem?

      Regards
      Marc

       
    • Nobody/Anonymous

      yep, but seems like some can get it to work some cant i guess we just have to wait

       
      • Heinkki Tanaka

        Heinkki Tanaka - 2008-03-05

        Hi all.

        I'd download the DIMDIM 3.0.0_Beta(05012008.
        I'd download Open Office OOo_2.3.1_Win32Intel_install_wJRE_en-US.exe.

        Install Open Office.
        Install dimdim.exe. (with 192.168.0.2)

        The public static IP is in Linux Fedora6 machine. (Internet 200.x.x.x and LAN 192.168.0.1).
        My DIMDIM server is a Windows XP SP2 (without firewall or any block), in LAN (192.168.0.2).

        All machines at LAN access the DIMDIM ok! Perfect!

        I need to access DIMDIM from internet.
        I'd configure rules in my Linux Firewall to redirect the ports:
        iptables -t nat -A PREROUTING -p TCP -s 0/0 --dport 80 -j DNAT --to-destination 192.168.0.2
        iptables -t nat -A PREROUTING -p TCP -s 0/0 --dport 1935 -j DNAT --to-destination 192.168.0.2
        iptables -t nat -A PREROUTING -p TCP -s 0/0 --dport 40000 -j DNAT --to-destination 192.168.0.2
        iptables -t nat -A PREROUTING -p TCP -s 0/0 --dport 40001 -j DNAT --to-destination 192.168.0.2

        BUT... Doesn't work.

        In external machine, I type http://externalIP/ and return this:
        -------------------------------------------------------
        404 Not Found
        The path '/' was not found.

        Traceback (most recent call last):
          File "C:\Program Files\OpenOffice.org 2.3\program\python-core-2.3.4\lib\site-packages\cherrypy\_cprequest.py", line 551, in respond
            cherrypy.response.body = self.handler()
          File "C:\Program Files\OpenOffice.org 2.3\program\python-core-2.3.4\lib\site-packages\cherrypy\_cperror.py", line 198, in __call__
            raise self
        NotFound: (404, "The path '/' was not found.")
        Powered by CherryPy 3.0.1
        -------------------------------------------------------

        But http://externalIP/dimdim/ don't return anything. Blank page!
        I tried with IE7 and FF, always on external machine.

        I'd see https://sourceforge.net/forum/message.php?msg_id=4762613
        But doesn't work again.

        C:\Program Files\Dimdim\MeetingServer\Conference Server\Tomcat 5.5\webapps\dimdim\WEB-INF\classes\resources\streaming.properties
        - streaming_server.1.rtmp_url=rtmp://200.x.x.x/
        - streaming_server.1.rtmpt_url=rtmpt://200.x.x.x:40001/

        C:\Program Files\Dimdim\MeetingServer\Conference Server\Tomcat 5.5\webapps\dimdim\WEB-INF\classes\resources\dimdim.properties
        - dimdim.serverAddress=200.x.x.x
        - dimdim.serverPortNumber=80
        - dimdim.dmsServerAddress=200.x.x.x:80

        C:\lighttpd\etc\lighttpd.conf
        server.port = 80
        server.bind = "192.168.0.2"

        -------------------------------------------------------

        Resuming: for machines on LAN dimdim work perfect! Machines on internet, doesn't work.
        The nat rules in Linux box are active.

        Any help?
        Thanks!

        Heinkki.

         
    • Rajesh Dharmalingam

      Hi Guys,

      For the latest Windows/Linux Dimdim 3.0.0 installer, you need to open ports 80, 1935 and 40001 while accessing behind firewall. With these 3 ports open, Dimdim can be accessed across firewall. 

      After opening the ports, you can try telnet to the following from the presenter's machine:
      Open a command prompt and do 
      telnet <external ip address> 80
      telnet <external ip address> 1935 
      telnet <external ip address> 40001
      If you get a connection timed out, Dimdim server is not running. If you get Connection refused, the firewall blocked access to that ports.

      To access Dimdim across firewall: use http://<external ip address>/dimdim/

      Please feel free to email us with detailed steps, if you are facing any issues on this regard to support@dimdim.com.

      Regards,
      -Rajesh
      rajesh@dimdim.com

       
    • Mauricio Mora

      Mauricio Mora - 2008-06-19

      All,

      I had exactly the same problem, apparently many people have the same issue with the beta version 3 running in windows, my system is a windows xp pro sp2:

      here my solution:

      1. download and install open office 2.3.1, use the default settings

      2. download and install dimdim 3.0 beta for windows, use the default settings

      3. set your dimdim server with a static IP address and disable the windows firewall in the interface properties.

      4. configure port forwarding in your firewall (depends on the firewall vendor the name will change, some other names i I have seen are: port mapping, static PAT, NAT etc.) just make sure external requests in TCP ports 80, 1935 and 40001 are being send to your dimdim server

      5. go to C:\Program Files\Dimdim\MeetingServer\Conference Server\Tomcat 5.5\webapps\dimdim\WEB-INF\classes\resources

      edit the file "streaming.properties", change the ip addresses of the following lines with your public IP address:
      streaming_server.1.rtmp_url=rtmp://x.x.x.x/
      streaming_server.1.rtmpt_url=rtmpt://x.x.x.x:40001/

      edit the file "dimdim.properties" to use your public ip address:

      dimdim.serverAddress=x.x.x.x
      dimdim.serverPortNumber=80
      dimdim.dmsServerAddress=x.x.x.x:80

      6. go to C:\Program Files\Dimdim\MeetingServer\Conference Server\Tomcat 5.5\conf and edit the file "server.xls" , find the following line:

      <Host appBase="webapps" unpackWARs="true" autoDeploy="true" xmlValidation="false" xmlNamespaceAware="false" name="x.x.x.x">

      replace the ip address of the "name=" space with your public ip address

      7. (optional) go to C:\lighttpd\etc, edit the file "lighttpd.conf", find the following line:
      #server.bind                = "grisu.home.kneschke.de"

      and replace it:

      server.bind                = "y.y.y.y"

      where y.y.y.y is the server private ip address

      8. Reboot the server

      Side Effect: Dimdim will only work from the internet and not in your LAN anymore.

      Regards,
      Mau
      mauricio.mora@sykes.com

       
    • Nobody/Anonymous

      I installed the latest VMWare Dimdim appliance and it will only work from the internet and not in my LAN. I tried different ways. I only to suceeded to make it work either only from internet or from LAN. I cannot make it work in a way it can be sued both from the internet and LAN. The whole point is moot as I am hosting meeting from inside my LAN to people who are outside.

      Any help is appreciated

      Thanks
      Sunny Singh

       
      • dimdim_diwakar

        dimdim_diwakar - 2009-01-12

        Hi,

        What i understood from your message is that you want Dimdim server on your LAN and invite people who are outside.
        Correct me if i am wrong.
        How it can be possible, people those who are not part of your LAN how can they access dimdim server.

        Regards,
        Diwakar

         

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks