Appliance not working out of the box

2009-03-17
2013-05-01
  • Rajiv Mehra

    Rajiv Mehra - 2009-03-17

    Ok, so I downloaded the Dimdim from:

    http://downloads.sourceforge.net/dimdim/Dimdim_VMWare_Appliance_v4.5.zip?use_mirror=superb-east

    I put it in my VMware server and fired it up. the CentOS does come up as it should and it seems to me that the dimdim processes have started up.

    But I still cannot access this URL:
    http://<ip of vm>/dimdim/

    As per the Dimdim_SF_VMWare_Appliance_ReadMe_v4.5.txt file I have tried this:

    Start Dimdim Components:

    cd /usr/local/dimdim
    ./StartDimdim.sh
         

    Stop Dimdim Components:

    #cd /usr/local/dimdim
    ./StopDimdim.sh

    <b>What to do??? Please help! </b>

    Is there a log somewhere I can look at???

    The end of the console output while starting dimdim using the above script says:

    Reflector started
    ....
    red5 server started
    ....
    Cobmanager Started

    [sorry cant post the whole output, the clipboard is not getting mapped :-(    ]

    So it looks like that the dimdim processes have started.....no errors.

     
    • Kevin Micalizzi

      Kevin Micalizzi - 2009-03-18

      On my laptop I had to enable incoming connections for VMWare before I could access my open source Dimdim is it possible you have firewall software preventing traffic to the appliance?

      Thanks.

      -k
      Kevin Micalizzi, Community Manager
      Dimdim Web Conferencing
        e: kevin@dimdim.com
        twitter: @dimdim
        facebook: dimdim.com/facebook

       
    • Rajiv Mehra

      Rajiv Mehra - 2009-03-18

      Hi Kevin,
      No I don't have any firewall up and running on the host server.

      I can ping this VM appliance successfully from my workstation too.

      Curiously, I cant fire up any web-browser on your CentOS VM. Is it not included ?

       
    • Rajiv Mehra

      Rajiv Mehra - 2009-03-18

      solution:

      You need to run /usr/local/dimdim/Config-ipaddress.pl to make dimdim aware of what IP and port to use. For example:

      Config-ipaddress.pl 128.59.x.x 80

      then Restart DIMDIM using the script (mentioned in the readme file) and viola ! it works!

      I hope that the readme included this information. I wasted a good part of a day to find this info!

      Now lets see how it works

      -Rajiv

       
    • Pankaj Gupta

      Pankaj Gupta - 2009-09-07

      Hey Rajiv,
      Which IP you provided to "Config-ipaddress.pl"?
      Is it the ip of eth0 on local machine or an external ip?

      I have tried it with ip of eth0 on local machine, but not working........is that right?

      -Pankaj

       
  • Kevin Josue Zambrano Chavez

    Hi everyone!

    I solved this problem using the &quot;Config-ipaddres.pl&quot; in this order:

    1) Stop all Dimdim components

    /usr/local/dimdim/StopDimdim.sh

    2) Set the IP address of my server

    /usr/local/dimdim/Config-ipaddress.pl X.X.X.X 80

    3) Start all Dimdim components

    /usr/local/dimdim/StartDimdim.sh

    After that, i could get into dimdim with my browser.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks