Documentation

Help
2007-05-13
2013-05-01
  • Stuart R Mealor

    Stuart R Mealor - 2007-05-13

    Hi
    I am really struggling with installing DimDim
    (I've seen it working at a conference and it looked very promising)
    I'm really not sure where the '.bash' file I'm supposed to edit is located.
    Also, the Readme is quite technical
    Is there any better documentation?
    Thanks, Stuart.

     
    • Rajesh Dharmalingam

      Hi Stuart,

      Thanks for using Dimdim and providing us feedback. I think you have tried with the tarball version of dimdim. There is another version with rpm package which will do all the post configuration for Dimdim install. Could you please try that and let us know if you face issues.

      Regards,
      -Rajesh

       
    • Stuart R Mealor

      Stuart R Mealor - 2007-05-14

      Hi Rajesh - thanks for quick suggestion :-)
      I tried with .rpm but I am totally comfused regarding Java now...
      Get the following error:
      error: Failed dependencies:
              /bin/sh is needed by dimdim-1.6-1.i386
              jre >= 1.5 is needed by dimdim-1.6-1.i386
              libc.so.6 is needed by dimdim-1.6-1.i386
              libc.so.6(GLIBC_2.0) is needed by dimdim-1.6-1.i386
              libc.so.6(GLIBC_2.1) is needed by dimdim-1.6-1.i386
              libc.so.6(GLIBC_2.1.3) is needed by dimdim-1.6-1.i386
              libpthread.so.0 is needed by dimdim-1.6-1.i386
              libpthread.so.0(GLIBC_2.0) is needed by dimdim-1.6-1.i386
              libpthread.so.0(GLIBC_2.1) is needed by dimdim-1.6-1.i386
              sed is needed by dimdim-1.6-1.i386

      Thing is, I have installed jre1.5 - can see it listed
      (I'm using Ubuntu Dapper LTS - finding jre1.5 took forever, very awkward :-()
      But when I do:
      java -version
      It says:
      java version "1.4.2"
      gij (GNU libgcj) version 4.1.0 (Ubuntu 4.1.0-1ubuntu8)

      Any Ubuntu users can help???
      :-(
      Stuart

       
    • Rajesh Dharmalingam

      Hi,

      Could you please let me know the following:
      1. <root>#env | grep JAVA_HOME.
      2. jre1.5.x path?
      3. <root>#rpm -qa | grep java

      Regards,
      -Rajesh

       
    • Stuart R Mealor

      Stuart R Mealor - 2007-05-15

      Hi Rajesh
      I logged in as root
      Typing the commands 1. and 3. above produced no output?

      I did a search for jre1* and found "jre" folders in:

      /usr/lib/jvm/java-1.4.2-gcj-4.1-1.4.2.0
      /usr/lib/jvm/java-1.5.0-sun-1.5.0.06

      Also a folder "jre1.6.0_01" in /usr/java

      Should I try uninstalling all 1.4 and 1.6 files?

      I'm sure DimDim will be great if I can get past the (unusual) awkwardness Ubuntu seems to have with jre!
      Stuart :-)

       
    • Rajesh Dharmalingam

      Hi Stuart,

      Thanks for the updates. Without uninstalling the existing java installs, could you please try installing a rpm version of jre1.5.x and see if that solves your problem?

      Regards,
      -Rajesh

       
    • Stuart R Mealor

      Stuart R Mealor - 2007-05-16

      Hi Rajesh - thanks for the help :-)

      I did a check on my installed version (on Java site), and it said v5.0 update 6
      It recommended v6 update 1

      I couldn't even find 1.5.x  (1.4.2_13 was the latest)
      So I elected for jre-6u1-linux-i586-rpm.bin

      As root, I copied it to /usr/java (recommended location given on java site)

      However, when installing it gave me lots of failed dependencies (see below)
      Is this usual?
      I can't see how /usr/ls for example can be 'missing' as I use the command "ls" all the time!
      Very confused now :-(
      Sorry if these are 'stupid' questions (not related to DimDim!)
      Stuart
      * * *

      Do you agree to the above license terms? [yes or no]
      yes
      Unpacking...
      Checksumming...
      Extracting...
      UnZipSFX 5.50 of 17 February 2002, by Info-ZIP (Zip-Bugs@lists.wku.edu).
        inflating: jre-6u1-linux-i586.rpm
      error: Failed dependencies:
              /bin/basename is needed by jre-1.6.0_01-fcs.i586
              /bin/cat is needed by jre-1.6.0_01-fcs.i586
              /bin/cp is needed by jre-1.6.0_01-fcs.i586
              /bin/gawk is needed by jre-1.6.0_01-fcs.i586
              /bin/grep is needed by jre-1.6.0_01-fcs.i586
              /bin/ln is needed by jre-1.6.0_01-fcs.i586
              /bin/ls is needed by jre-1.6.0_01-fcs.i586
              /bin/mkdir is needed by jre-1.6.0_01-fcs.i586
              /bin/mv is needed by jre-1.6.0_01-fcs.i586
              /bin/pwd is needed by jre-1.6.0_01-fcs.i586
              /bin/rm is needed by jre-1.6.0_01-fcs.i586
              /bin/sed is needed by jre-1.6.0_01-fcs.i586
              /bin/sort is needed by jre-1.6.0_01-fcs.i586
              /bin/touch is needed by jre-1.6.0_01-fcs.i586
              /usr/bin/cut is needed by jre-1.6.0_01-fcs.i586
              /usr/bin/dirname is needed by jre-1.6.0_01-fcs.i586
              /usr/bin/expr is needed by jre-1.6.0_01-fcs.i586
              /usr/bin/find is needed by jre-1.6.0_01-fcs.i586
              /usr/bin/tail is needed by jre-1.6.0_01-fcs.i586
              /usr/bin/tr is needed by jre-1.6.0_01-fcs.i586
              /usr/bin/wc is needed by jre-1.6.0_01-fcs.i586
              /bin/sh is needed by jre-1.6.0_01-fcs.i586

      Done.

       
    • Rajesh Dharmalingam

      Hi Stuart,

      Thanks for the updates. Will it be possible for you to provide access to your machine so that we will try to troubleshoot? If so, could you please mail me those details to rajesh(@)dimdim.com.

      Regards,
      -Rajesh

       
    • Rajesh Dharmalingam

      Hi Stuart,

      You can find jre-1_5_0_10-linux-i586.bin from https://sdlc4e.sun.com/ECom/EComActionServlet;jsessionid=652ADD98845176ACC2C82BDF4729DD9B.

      Could you please download and try this. Let me know if this solves your problem.

      Regards,
      -Rajesh

       
    • Stuart R Mealor

      Stuart R Mealor - 2007-05-17

      Wow
      Thanks Rajesh
      I'll try this at the weekend :-)
      Stuart

       
    • Stuart R Mealor

      Stuart R Mealor - 2007-05-19

      Hi Rajesh
      Finally found jre-1_5.x - thanks :-)

      I think my system must be broken though :-(
      When installing I get the following...
      Even though I KNOW (for example) fileutils 5.93.x IS installed
      I think my installer may be broken???
      Stuart

      Extracting...
      UnZipSFX 5.42 of 14 January 2001, by Info-ZIP (Zip-Bugs@lists.wku.edu).
      replace jre-1_5_0_10-linux-i586.rpm? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
        inflating: jre-1_5_0_10-linux-i586.rpm
      error: Failed dependencies:
              glibc >= 2.1.2-11 is needed by jre-1.5.0_10-fcs.i586
              sh-utils >= 2.0-1 is needed by jre-1.5.0_10-fcs.i586
              fileutils >= 4.0-8 is needed by jre-1.5.0_10-fcs.i586
              gawk >= 3.0.4-1 is needed by jre-1.5.0_10-fcs.i586
              textutils >= 2.0-2 is needed by jre-1.5.0_10-fcs.i586
              /bin/sh is needed by jre-1.5.0_10-fcs.i586

      Done.
      root@stuart-laptop:/usr/java#

       
    • Rajesh Dharmalingam

      Hi Stuart,

      Thanks for the updates. I think you can try the installation in another desktop or in a VMware. Also, try if you can install any other application.

      Regards,
      -Rajesh

       
    • Rajesh Dharmalingam

      Hello Stuart,

      Could you please let us know if the issue got resolved?

      Regards,
      -Rajesh

       
      • Stuart R Mealor

        Stuart R Mealor - 2007-06-01

        Hello Rajesh

        At this point I am unable to work on it further.
        I need another server as I can't test in detail on a live one.
        I don't think it's a DimDim specific issue.
        Ubuntu JRE isn;t good (not 1.5 anyway).
        I will wait until DimDim works with JRE6, or has a specific installer for Ubuntu.
        Product looks great, and Moodle addin is essential.
        Keep up the great work!
        Stuart

         
    • Rajesh Dharmalingam

      Hello Stuart,

      Thanks for the updates. Dimdim-Moodle Integration pack is release and available at location https://sourceforge.net/project/showfiles.php?group_id=176809&package_id=228683. On installation of dimdim integration pack with moodle, Moodle will use default settings that is pointing to a dimdim-hosted server. Try this and let us know if you are facing with any issues.

      Regards,
      -Rajesh

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks