Help save net neutrality! Learn more.
Close

Strange Problem

Help
Victor
2007-12-14
2013-03-24
  • Victor

    Victor - 2007-12-14

    I have used your utility many times . and last week I encoutnered a strange problem .
    The Environment is :
    New Installed Xp OS,
    Installed .net 2.0
    Installed your software up-to-date version .

    When I run it , it error occured. When I use CLR_Debug to debug it . It show me the DILE.Debug file not found .
    But the file is exist in the application execute folder.
    So ,could you give some advice how to solve this problem ? or how to debug this ?

     
    • Petrény Zsolt

      Petrény Zsolt - 2007-12-14

      Hi,

      Unfortunately, this problem is quite common. I think, installing the VC++ SP1 runtime will solve it. You can find it here:

      VC++ Runtime SP1 for 32-bit Windows (x86): http://www.microsoft.com/downloads/details.aspx?familyid=200b2fd9-ae1a-4a14-984d-389c36f85647&displaylang=en
      VC++ Runtime SP1 for 64-bit Windows (x64): http://www.microsoft.com/downloads/details.aspx?displaylang=en&familyid=eb4ebe2d-33c0-4a47-9dd4-b9a6d7bd44da

      Basically, the problem is that the Dile.Debug.dll is a mixed C++ dll (it contains both managed and unmanaged code) and therefore it depends on the VC++ SP1 runtime.

      Please, let me know whether whether installing it really helps.

      Regards,
        Zsolt Petreny

       
    • Victor

      Victor - 2007-12-24

      yes  .
      The problem has been solved.

       
    • Victor

      Victor - 2008-05-13

      The Problem is due to when use C++/CLI assembly, it will need manifest.
      it is embedded in the assebmly by default.
      And the manifest write a line indicate this assembly depend on a CLI runtime library ,and this library is included in VC++ Runtime.
      So after install VC++ Runtime ,this problem will be solved.

       

Log in to post a comment.