My XDebug Problem Fixes

  • David Pratt

    David Pratt - 2009-12-21

    I was having problems configuring XDebug to begin with, but found out I needed to enclose the zend_extension directory parameter in double quotes and then reboot the computer to get it to work.

    Then,  I was having problems with getting XDebug to work, and from looking at the threads here, it seemed to be a common problem. I was in the process of trying to see if anyone had come up with a solution when I stumbled across one on my own.   I was operating with following setup:

    OS: Windows 7 64bit Home Premium edition

    HTTP Server: Apache 2.2

    PHP version: 5.3.1 VC6.0 Threadsafe

    IDE: Dev-php 2.3.2 with XDebug installed

    I had originally configured my Apache server to listen on port 80, and Dev-php as well.  I kept getting a port conflict error every time I tried to save my config settings.  I was also experiencing the following error: My activate debug button would not gray out when I clicked on it.  I finally tried changing the web server port in Dev-php and the Apache server's listening port in the http.conf file to 8080 and everything came alive.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks