IDE vs Editor

dt30
2006-08-01
2012-12-07
  • dt30

    dt30 - 2006-08-01

    I'm sorry, but for some reason I'm having a hard time understanding the differences.  Once I downloaded an alpha version of the editor, but I couldn't see much to it.

    Does the editor not have any Integrated Development Environment to it?  Specifically, if I used the editor, would I be able to run PHP from it to test programs and see the resulting page and debug them?

    If so, how is that different from the 2.0 IDE?

     
    • Urs Mäder

      Urs Mäder - 2006-08-02

      hello

      there are:
      -internal webserver
        with internal and external preview
      -ftp client with sync function
      -filebrowser
      -printpreview
      -BOTS and snippets
      -extended search functions with regex and search in directorys
      - ... and more

      urs maeder

       
    • dt30

      dt30 - 2006-08-02

      I just finished downloading and installing PHP Editor 3.0 for my Windows 98 machine.  I wrote a simple program that echoed "hello".  I set the compiler to point to the one I was using in 2.0.  Clicking on the Internal browser tab didn't do anything.  Clicking on script, compile and run caused a beep and then I couldn't edit the program any more.  I found clicking the red abort button displayed "aborted by user" in the internal browser and then I could edit the program.  I couldn't find anything about FTP.

      Do I need to download a debugger before these things will work?  Am I missing something (to download or knowledge of how to work it)?

      dt

       
      • Urs Mäder

        Urs Mäder - 2006-08-03

        editor 3.0 has no ftp etc.
        the problems about running scripts i need more information to help you. and... i cannot support windows98 because i have it not.

         
    • dt30

      dt30 - 2006-08-03

      I must have misunderstood which one had the FTP.  I entered in the 3.0 editor the following:
      <?php
      echo "hello";
      ?>

      Then, what should I do, and what should I see?  Do you really think windows 98 could be causing a problem?

      I think I'll try the updated version of 2.13

       
      • dt30

        dt30 - 2006-08-04

        I installed the 2.13.261 and it will show .html files in the internal preview, but not .php (or .php3).  I uninstalled it and reinstalled 243.  It works.  So then I reinstalled 261 in a separate directory, it doesn't work and the "project" menu is changed to "! <ERR: 9>".

        I found deleting windows\application data\devphp.ini and then restarting 261 will remove the error from the menu name.  However, no matter what order I delete the .ini file and run 243 or 261, 261 will not preview a php file while 243 will.  I set the parser php directory to the same for both.

        I wonder if whatever reason is the same why 3.00 won't work for me.  I noticed the 261 update list says "Internal Preview : Really restricted to localhost".  Could this have something to do with no preview?  When I hit refresh in 243 and 261, the status line on both says, "Opening page http://localhost:8080/testfile.php..."  I have it stored in "My Documents".

         
        • Urs Mäder

          Urs Mäder - 2006-08-05

          i fact dev-php-ide and dev-php-editor are two different programs with a same code base. you cannot  talk about both versions....

          may be the error comes from settings about the local server path or php.ini. please report your setting in options - dialog/localWebServerPath. thanks.

           
          • dt30

            dt30 - 2006-08-06

            Local web server path is:
            C:\My Documents\ which is where the files are.

            Version .243 works with .html and .php files.
            Version .261 only works with .html files and does not work with .php files.

            Something must have changed between the two versions that prevents running .php files. 

            It's almost like the php parser is not being invoked in .261

            If I click Options, Edit php.ini, it finds the same file.

             
            • Urs Mäder

              Urs Mäder - 2006-08-06

              ouups!!!!
              i think i have found the problem.
              pfa has restricted the localwebserver to 127.0.0.1 but may be that localhost and 127.0.0.1 is not the same... i will fix this thanks.

              urs maeder

               
            • Pierre Fauconnier

              Hi,

              > Version .261 only works with .html files and does not work with .php files
              > It's almost like the php parser is not being invoked in .261

              That sounds like a bug that appeared with revision 246. From time to time, the property "PHPSupport" of the component "idCGIRunner" resets to False.
              The effect is exactly the one reported here and special care is taken on this property. However it was limited to designing state only.

              Furthermore, i'm not able to reproduce this error - included with a 2.0.13.261
              But i'm sure there's a bug / memory leak
              Could you help to reproduce, please ?

              Pierre.

              Nota bene : imho this has nothing to see with 127.0.0.1 (my firewall is reporting a security hole with ip address 0.0.0.0, and reports nothing as soon as we're using 127.0.0.1 ;)

               
              • dt30

                dt30 - 2006-09-11

                Pierre,

                Not sure what you need to reproduce the problem.

                I'm running Windows.  Version 243 works the same as previous versions (I haven't downloaded the "full package" since 12. from March, 2005 - problem?).  But, when I run 261, and click on the Internal Preview tab, nothing is shown.  Index.html works as expected, but nothing for Index.php.  Nor for any .php.  Whether the .php is pure php code or html code.

                What is this "idCGIRunner"?  Is there somewhere I can set it to true for the runtime?

                A side question:  I notice there there "appears" to be internet activity when I start up either version.  I don't know that I have any directories options set non-local.  Is the program checking something on the internet?

                 
                • Pierre Fauconnier

                  > I haven't downloaded the "full package" since
                  > 12. from March, 2005 - problem?
                  Not at all. Full package integrates php-cgi.exe, php5ts.dll, php.ini and php_xdebug.dll (and some other exe and dll, of course - although we don't really need them).
                  I'm thinking of 'certified' packages with different versions of PHP - i'm running without problem versions 4.4.1, 5.0.2, 5.1.2 and php_gtk 1.0.2 - all these included corresponding Xdebug.

                  > What is this "idCGIRunner" ?
                  It is an internal component, used to fork php-cgi.exe

                  > I can set it to true for the runtime ?
                  Unfortunately there's no parameter to do so.

                  > A side question: ... internet activity ...
                  > Is the program checking something on the
                  > Internet ?
                  AFAIK, Internal preview and Xdebug are binding/connecting to localhost only (127.0.0.1) - there's no security hole, once again as far as i know.

                  Would you please test the last Exp version
                  http://devphp.sf.net/2.0/devphp2.exe [1.38 MB]

                  Thanks for your report,
                  Pierre.

                   
                  • dt30

                    dt30 - 2006-09-11

                    Thanks for answering my questions.

                    I'm using Internet Explorer by the way.  Don't know if that makes a difference.

                    I downloaded the file and put it in my version 261 directory.  Still, just a blank screen for php files and works ok for html files.

                    I was looking around at the menu and never had tried the "syntax check" option.  I tried that and received the following.  (This only happens the first time, but not following times while the editor is still loaded.  The directory and file do exist):

                    PHP Startup: Unable to load dynamic library ......\php\ext\php_fdf.dll - One of the library files needed to run this application cannot be found.

                    PHP Warning: PHP Startup.....(same path)
                    in Unknown on line 0

                    I just never had tried it in v243 before, but it says that php5ts.dll is needed and to please select.  So, I do, and then it says ....\php5ts.dll\php5ts.dll not found.  The selection window won't let me select a directory only.

                    I wasn't necessarily wanting to check syntax, but only wondered if it may have something to do with the problem.

                    If I change the web server directory to the root level, I get "Not Found" for html, but still a blank page for php.  In v243, I get "No input file specified." for php files.  It's like the php parser isn't running.

                     
                    • Pierre Fauconnier

                      I wrote a special installer with nsis
                      http://devphp.sf.net/2.0/Dev-PHP_envir.exe [5.96 MB]

                      1- Could you run it, please ?
                      It will install
                      - Dev-PHP last experimental version (only the devphp.exe and
                      its uninstall.exe)
                      - 4 _certified_ environments
                      o PHP 4.4.1, 5.0.5, 5.1.2
                      o PHP-GTK 1.0.2
                      - 1 little project with some small files

                      At the end, the installer will launch the Dev-PHP program

                      2- Could you change the path for php-cgi and php.ini ?
                      Menu Options » General Options
                      Select the third tab then
                      Enter %instalDir%PHP_411\php.exe in the first field
                      And %instalDir%PHP_411\php.ini in the second field
                      Click Ok

                      3- Could you open the little project ?
                      Menu Project » Open project...
                      Select %instalDir%CHECK\project.prd

                      Does the included 'index.php' work now ?

                      Anyway, there's no risk : since it's buit with nsis, you can
                      run %instalDir%uninstall.exe

                      where %instalDir% has to be replaced by the path selected when installing.

                      Sincerely yours,
                      Pierre.

                       
                      • dt30

                        dt30 - 2006-09-16

                        Thanks for introducing me to nsis.  Neat program.

                        I downloaded and installed the software.  I thought it changed the fonts for the program, but setting the directories as you instructed did not work.  If I saved the php as html, then Internal preview would show the code.  Otherwise, I heard the disk process stuff, but blank window.  I tried setting directories to each of the others, 505, 512, and GTK, but no difference.  I almost think it is processing the code, but not showing it.

                        Any thing else to try?

                         
                        • Pierre Fauconnier

                          Many thanks for your patience.

                          > I thought it changed the fonts for the program
                          May be : the dialog font declared in the provided project file is Verdana.

                          > Any thing else to try ?
                          1- Could you zip (7z is a good program too) your directory %APPDATA%\devphp and mail it to me
                          2- Could you then rename or remove this directory %APPDATA%\devphp and launch Dev-PHP once more

                          Best regards,
                          Pierre.

                           
      • dt30

        dt30 - 2006-08-16

        In regards to the 3.0 editor, I was still trying to figure out how to make it work.  I found some stray hidden tasks in my task list (php_win or something like that), and tried to end one.  It popped up the hidden message about not being able to find .\ext\php_fdf.dll and several others.  (I tried both "/" and "\&quot;) I thought that's strange, because it existed right where the rest of 2.x was able to find it fine and where I set the compiler to in 3.x. 

        I thought, just for fun, rather than using the relative path ".\ext", I'd put in the complete absolute path for extension_dir.  Still clicking on the internal browser tab did nothing, but clicking on compile and run, WORKED!  (You're right, the two environments are different)

        So, it appears 2.x can use a relative path, but 3.x cannot use the same relative path but will work with an absolute path for the "extension_dir".

        I still have not found the debugger to do anything.  :-(

         

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks