hi
i have a problem booting from a ext2 parttition.
i copy all devil linux stuff from cd to hda4.
on hda1 i have the boot partition and i copy all stuf from cd /boot to
hda1 /boot/devil.
the next step is to config lilo to boot the kernel from /boot/devil/vmlinuz
the append line in lilo is :
append = "initrd=/boot/devil/initrd.gz root=/dev/ram0 init=/linuxrc rw"
the kernel starts now but i get the error :
-------------------------------
FAT : bogous cluster size 0.
FAT : bogous cluster size 0.
read_super_block: can't find a reiserfs filesystem on (dev 01:00, block
64 size 1024)
read_super_block: can't find a reiserfs filesystem on (dev 01:00, block
64 size 1024)
Kernel panic: VFS: Unable to mount root fs on 01:00
-----------------------------------
is this a kernel or a lilo or a filesystem problem ?
how can i fix it ?
here is my complete lilo.conf
-------------------------------------
append="hdd=ide-scsi"
boot=/dev/hda
vga=normal
message=/boot/message
menu-scheme=Wg:kw:Wg:Wg
read-only
prompt
timeout=80
# End LILO global Section
#
image = /boot/vmlinuz
root = /dev/hda3
label = linux
#
image = /boot/devil/vmlinuz
# root = /dev/hda4
label = devil
append = "initrd=/boot/devil/initrd.gz root=/dev/ram0 init=/linuxrc rw"
-----------------------------------------------
please help !!!
roland
|