Quoting Stuart Hastings <stuart@hastings.org>:

I burned a CD with 1.6.4-2013-02-27 this evening, and I tripped over a minor issue.
While my system was rebooting, 1.6.4 asked if I wanted to upgrade my configuration (1.6.3 -> 1.6.4).  I agreed to the upgrade, and it "broke" my configuration!  When DL finished booting, I logged into my personal (non-root) account on the DL box and tried "ping google.com", and it said (paraphrased)
icmp open socket; operation not permitted
I have no idea what this symptom might imply.  (Clues appreciated!)
Re-trying the ping from the root account worked, but other machines on my local network couldn't reach the internet; it seems they could get DHCP service from my DL box, but not much else. For example, DNS wasn't working at all ("ping: cannot resolve google.com: Unknown host").  (I didn't think to try pinging a valid IP address from a networked machine.  Duh.)
I reverted everything, did some experiments, and was able to get 1.6.4 working with an old configuration (old etc-mods.tar.bz2); this time, I did not agree to the upgrade.
I did think to preserve the troublesome auto-upgraded etc-mods.tar.bz2 file; I unpacked it alongside an older working counterpart and diff-ed the trees.  Alas, I see nothing in the diff that explains the failure to me.  I *must* be missing something, because it works with the older one, and fails with the newer, auto-upgraded one...
I'll spare you the diff, but here are the files that changed when I diff-ed the tarballs:
etc-mods/dnsmasq.conf (I added a comment)
etc-mods/group- (I added a local account)
etc-mods/shorewall/blacklist (I added a comment)
I don't know what's in the dhcpcd-eth0.lease file (I have only a guess), but it's not clear to me that it could be causing my troubles, either.  I think I understand all the rest of the differences, and I'm pretty certain none of them could have caused my breakage.  (Recall that the working config file was an older version, saved before I created my local account.)
Anyways, I have 1.6.4-2013-02-27 running now, and I can see afpd and afp.conf, so I can take my next baby next step towards Time Machine support. :-)  Any clues to help me understand how I broke the auto-upgrade would be greatly appreciated.  :-) :-)
Thank you very much for Devil Linux,


Yes this is certainly weird.
The file dhcpcd-eth0.lease stores the IP address which you got from the DHCP server, so the client can request the same one again after the reboot.
Is it possible that with the new config you IP address changed and that this may have caused troubles with a firewall rule which may have the old address configured?



  Heiko Zuerker