Ryan Michael - 2014-07-24

I'm trying to use the glut32 library, libglut32.a. I have dev c++ version 5.6.3. I can't for the life of me figure why I'm getting the errors I'm getting. Here are my errors:

skipping incompatible C:/Program Files (x86)/Dev-Cpp/lib/libglut32.a when searching for -lglut32
skipping incompatible C:/Program Files (x86)/Dev-Cpp/lib\libglut32.a when searching for -lglut32
skipping incompatible /lib/glut32.lib when searching for -lglut32
skipping incompatible C:/Program Files (x86)/Dev-Cpp/lib/libglut32.a when searching for -lglut32
skipping incompatible /lib/glut32.lib when searching for -lglut32
skipping incompatible /lib\glut32.lib when searching for -lglut32
cannot find -lglut32

Now when I go to Project->Project Options->Parameters Tab->Linker, I have these libraries set:

-lopengl32 -lwinmm -lgdi32 -lglu32 -lglut32

And, when I go to Project->Project Options->Directories Tab->Library Directories Tab, I have these Library paths set:

C:\Program Files (x86)\Dev-Cpp\lib
C:\Program Files (x86)\Dev-Cpp\MinGW64\lib
C:\Program Files (x86)\Dev-Cpp\MinGW64\x86_64-w64-mingw32\lib

If you take a look at where my libglut32.a is located, it shouldn't have a problem unless there are other settings I'm not aware of. There are only a couple libraries that I have tried that result with errors. Anyway, the file path that libglut32.a is this:

C:\Program Files (x86)\Dev-Cpp\lib\libglut32.a

If anyone knows what the problem is I would appreciate any help you can give. I'm inclined to think it's either a compiler issue or a libglut32.a issue. Probably the former since I have more library files with the same issues. But, I could be wrong.

 
Last edit: Ryan Michael 2014-07-24