C:\Dev-Cpp\Makefile.win [Build Error]

Paula
2009-11-29
2013-10-13
  • Paula

    Paula - 2009-11-29

    Hi,

    I'm new to using Dev C++ and I'm using version 4.9.9.2 on Windows 7. I'm
    trying to compile a project and I keep getting this error.

    C:\Dev-Cpp\Makefile.win Error 1

    I can compile the file as a source file without any errors so it shouldn't be
    any errors in the code.

    This also comes up in the Compile Log.

    Compiler: Default compiler
    Building Makefile: "C:\Dev-Cpp\Makefile.win"
    Executing make...
    make.exe -f "C:\Dev-Cpp\Makefile.win" all
    gcc.exe -c input.txt -o input.o -I"C:/Dev-Cpp/include"
    gcc.exe: input.txt: linker input file unused because linking not done
    gcc.exe main.o input.o -o "Assembler.exe" -L"C:/Dev-Cpp/lib"
    gcc.exe: input.o: No such file or directory
    make.exe:
    * Error 1
    Execution terminated

    Any help or pointers would be appreciated.

    Thanks

     
  • cpns

    cpns - 2009-11-29

    I advise strongly against building your project in C:\Dev-Cpp. Not only is it
    just a bad idea to pollute the installation folder, there is a bug in Dev-C++
    that causes projects in C:\Dev-Cpp\ or its sub-folders to sometimes fail to
    build.

    Secondly, in general if you have a problem getting a tool to work, it is
    unwise to be doing something unnecessarily and gratuitously unusual; and I
    would suggest attempting to compile a .txt definitiely falls into the
    unusual category, if not the downright bonkers!

    I also suggest that you post logs in code mark-up rather than italics to
    preserve line breaks correctly.

     
  • laxman varada

    laxman varada - 2010-08-16

    hi,

    also suggest that you post logs in code mark-up rather than italics to
    preserve line breaks correctly.

    regards,
    phe9oxis,
    http://www.guidebuddha.com

     
  • ilin79

    ilin79 - 2013-10-13

    Try going to tools-compiler options-compiler and unselect the allowance of making fast but imperfect dependancy generation.

     

Log in to post a comment.