Help save net neutrality! Learn more.

Running des

  • AndrevS

    AndrevS - 2012-08-02

    I have tried downloading the Linux binairy package. (  DES3.0Linux32SICStus.tar.gz )
    This binary refuses to run due missing libraries.

    ./des: error while loading shared libraries: cannot open shared object file: No such file or directory

    I am running a 64 bit ArchLinux installation, and there appears to be no odbc package in the multilib repository.

    So, alternatively, I looked for a source distribution. I have downloaded the DES3.0GNU.tar.gz file and extracted it.
    Starting it using the GNU Prolog interpreter results in an error message

    $ gprolog -entry-goal 
    GNU Prolog 1.4.0
    By Daniel Diaz
    Copyright (C) 1999-2011 Daniel Diaz
    warning: command-line goal '' caused exception: error(syntax_error('constant term stream:1 (char:5) , | ] or operator expected in list'),read_term_from_atom/3)
    | ?-

    How do I run the program?

  • Fernando Saenz-Perez

    First, apologies for answering such too late but I was not aware of this message until now :-(
    Second, thanks for your interest in this system.
    Regarding your question, the first problem you faced with the binaries is because there are no ODBC libraries installed in your system. DES expects to be located at /usr/lib. I tested this with Ubuntu 12.04 32bit and installed the last release of unixODBC 2.3.1 (with ./configure -prefix /usr). But this installation produces instead of Then, I submit:
    ln -s /usr/lib/ /usr/lib/
    and it worked for DES to start.
    With respect to your second problem with the sources, I installed GNU Prolog 1.4.1 and couldn't start DES with:
    gprolog -entry-goal 
    This only started GNU Prolog (and no error as your installation). So, from its command interpreter, I simply submitted
    |?- .
    and this worked.
    Please tell me whether you are successful in starting DES. If you are not, I'll try to find another solution.
    All the best,


Log in to post a comment.