I made made a small fix to depdot. The new version is 0.5.4. The header file exclusion list has been extended a bit and POSIX headers (from 'sys) are also ignored now.

I am considering a change proposed by Nick in this forum. If this change is made it will go into version 0.6.0. I aim to take the opportunity to make it compatible with python 3 at the same time.