SourceForge has been redesigned. Learn more.
Close

Create Script Produces an Empty File

Help
2010-11-09
2013-03-06
  •  LiveFreeAndRoam

    LiveFreeAndRoam - 2010-11-09

    This is a follow up from topic MySQL syntax generated for SQLite Database

    I have tried to create scripts, and that has worked in the past.  The last time I did that, I received messages that I had circular references.  I attempted to fix them and next time I attempted to generate a script, it produced an empty file, although its size is 1kB.  I also tried to "Copy Script to Clipboard", but it was also empty.  I've checked the "All Tables" and every other check box on the page.  Same result.

    I tried changing the "Target Data Base:" from SQLite to MySQL.  Once again, an empty file is produced, although it is 1kB in size.

    Any ideas?

    LFaR.

     
  •  LiveFreeAndRoam

    LiveFreeAndRoam - 2010-11-18

    Ok, this was pilot error.  I had checked the box titled "Export selected Tables only" and had forgotten about it.  Since I was attempting to export "All Tables", I mistakenly overlooked the other checkbox.

    After unchecking "Export selected Tables only", I can once again create the scripts.

    As an aside, I wonder if it's practical to have a warning/error message pop-up when no tables are selected while "Export selected Tables only" is checked.  That way, if someone attempts to save or copy the script, the message would warn them about the misconfiguration.

    LFaR.

     

Log in to post a comment.