DBAN can't find my disks

  • Patrick Velliky

    Patrick Velliky - 2010-11-17

    I'm trying to run DBAN on a Proliant DL380 (G4) and I get the following error:

    Dban failed

    The disks have not been wiped
    Error : Disks not found. Dban could need a driver for this computer.

    press hold the power button and shutdown .

    I've tried running DBAN both from a bootable USB and a CD but get the same result.  Any advice for this?

  • Patrick Velliky

    Patrick Velliky - 2010-11-17

    Sorry, the original post didn't like my link to the server specs, this bit.ly link works.  http://bit.ly/7INb71

  • Kelly Weston

    Kelly Weston - 2010-11-18

    boot up with cd in bay after you have removed all usb readers.  also, unhook any hardrives that DO NOT need to be wiped

  • Patrick Velliky

    Patrick Velliky - 2010-11-18

    Thanks for the quick response, but no dice.  Still getting the same error message.

  • Patrick Velliky

    Patrick Velliky - 2010-11-18

    Looks like the issue is due to the RAID 5 configuration.  Apparently DBAN can't disassemble the RAID volumes on its own and I'll have to do it manually.

    Thanks for the input kellywas.

    We can consider this thread resolved.

  • Johnny Trev

    Johnny Trev - 2010-12-16

    To save you doing it manually (and for the record of this topic), it might be worth trying the nwipe tool included in Partition Magic. It's a fork of the same software as used in DBAN, but usable in any Linux distribution. Just download Parted Magic and go to nwipe in the menu. I think it may also be included in some other Live CDs.

  • Cable & Wireless

    The problem with the HP DL380's is not the fact that your disks are in a raid (though you should go into the Raid option rom and set every disk to Raid 0), It's the fact that DBAN doesn't know where to find the device files.

    Run it so it comes up with your error, then press ALT-F4 and Enter to get a shell

    In /etc/init.d edit the main script

    Search for SD_FOUND  and modify the /dev section to say /dev/cciss
    modify the sd to say c0d

    Then run the main script (./main) You should be good to go now.

    I've tried to rebuild DBAN to make this mod perm but I can't get the buildroot environment to work properly. I passed this mod onto the support email address for inclusion but no response yet.


  • Anonymous

    Anonymous - 2012-07-01

    When writing in "/etc/init.d" it says permission denied. What to do?

  • Bryan Dam

    Bryan Dam - 2012-12-17

    Thanks for the tip Andy, just nuked drives on a third generation DL380 with that info.  One thing I will add is that if there are multiple controllers you must select the correct controller number.  If you select a controller with no drives DBAN errors out.  If you change the regex to catch all controllers it will still error out if one of them is without a logical drive so you must change it to only select the controllers that are populated.

  • Anonymous

    Anonymous - 2013-01-15

    wiping 2 servers right now. been running dban for years and this will save time.
    c0d  change to cd if you have multiple controllers.

    ls -l /dev/cciss will show the disks that you have

  • Roger Andersson

    Roger Andersson - 2013-02-28

    Thanks Andy!!!
    dban now running on a DL380 G4 that had been retired, removing some sensitive data from 2 146GB 15K Ultra320.
    It looks like it will take some time ;-)

  • CG

    CG - 2017-10-11

    I know this thread is old now but I had the same issue with an HP Proliant DL380 G5. I was using the latest version of Dban which is version 2.3.0 and it wouldn't detect the drives, even after deleting the logical array and rebuilding it to RAID 0. I tried doing what Andy posted above about pressing Alt + F4 and entering the commands he posted. I received the same issue the Anonymous user posted after Andy in July 2012 about getting a permission denied error. Since no one answered his question, I found another thread that stated that the older dban version 1.0.7 can detect the disk drives. I tried this and it found my RAID 0 disks on the server.

    TL;DR - Used DBAN version 1.0.7, it found my RAID 0 configuration, and was able to wipe the disks.

    Last edit: CG 2017-10-11

Log in to post a comment.