DBAN won't load on a particular PC

  • Brent Boswell

    Brent Boswell - 2011-12-02


    Have been using DBAN 2.2.6 (beta) all day on several old PC's.  Got to one where it is being a stinker and not working.

    Several of the PC's that I have wiped today have had the AsRock K8Upgrade-VM800 motherboard in them (with nothing installed in AsRock's dorky upgrade slot).  It is an AMD Socket 754 MoBo.

    The particular PC that won't boot DBAN has the AsRock K8Upgrade motherboard in it.  The only thing that's different from the others that I've wiped today is that it has a Western Digital 80GB SATA II drive in it instead of an IDE/ATA drive.  I know that this motherboard has a VIA 8237 SATA controller in it.  The PC in question still boots its copy of Windows XP without user intervention, so I know it works.  Further, I can read the DBAN disk in the CD-ROM once the PC is booted in XP :)

    When the PC boots DBAN, I get the usual DBAN prompt, and press enter for the interactive DBAN session.  Then the screen clears, and in character mode says (in white text on a blue background) that DBAN is starting.  But now, I don't get the usual next text about detecting USB devices, and the cursor just sits there blinking.

    If I wait about five minutes, I get a black and white character mode message that "udevsettle prgoram failed with error 1".

    Any ideas?

  • Scott

    Scott - 2011-12-02

    Do you have SATA drives?  If so, then you can get DBAN to detect SATA hard drives by configuring the drive as AHCI instead of IDE emulation. In other words, If you have a SATA drive and DBAN does not detect it, try configuring to AHCI.

    Please post a reply as to whether this was helpful.  If you solve the problem on your own, please post the solution.

    • Randy Shattuck

      Randy Shattuck - 2013-07-30

      Thank you for that. I thought AHCI might be it but read this JUST as I was in the bios. Saw it was set to IDE...flipped it to AHCI and all worked great. Thanks for the post. Saved me from guessing more and this is also a conformation to others that it made the difference of dban recognizing the SATA drive and not recognizing it.

  • Brent Boswell

    Brent Boswell - 2011-12-02

    Apparently, the problem is limited to the one machine.

    There is no AHCI in this ancient BIOS, unfortunately :(

    I tried it in a second machine with an identical config (SATA II drive instead of IDE), and it works like a charm.

    I wonder if we skipped a BIOS update on the one machine about 5 years ago… ;)


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks