SOLVED non-fatal errors / process crash

1 2 > >> (Page 1 of 2)
  • Anonymous

    Anonymous - 2010-07-02

    I kept getting the non-fatal errors / process crash messages. After trying two different CD from two different machines, hooking up the drive I wanted nuked via eSATA and internal SATA. I found a link in another post that pointed me in the right direction (link below).

    I unplugged my external USB drive, my eSATA drive, all internal SATA drives except the one to be nuked and my optical drive. My card reader which is plugged into a USB header on the mobo had been showing up in dban as multiple drives. I disconnected that as well. I booted with the CD. The only drive to show up in dban was the one to be nuked. I started the process and SUCCESS!

    So, if you have SATA drives and are getting non-fatal errors / process crash then unplug every drive and anything that can show up as a drive (card readers etc.) before running dban.

    If this works for you leave a comment to bump the post and spread the word.

    The link:

    Using 2.2.6 beta

    System #1:
    GIGABYTE GA-X58A-UD3R Motherboard
    Intel Core i7-930 Bloomfield 2.8GHz
    CORSAIR XMS3 6GB (3 x 2GB) 240-Pin DDR3

    System 2:
    ABIT IP35 Pro Motherboard
    Intel Core 2 Duo E8400 Wolfdale 3.0GHz
    CORSAIR XMS2 4GB (4 x 1GB) 240-Pin DDR2

    • Nate

      Nate - 2013-08-05

      Hey guys/girls!
      I just wanted to thank everyone who added posts to this forum and helped identfy teething problems with installing DBAN! It has helped me immensely and after an evening of trying boot CD's and USB disks i finally managed to run DBAN successfully!
      My problems started with the actual installation of the iso file and i ignorantly tried to insallt the iso file directly onto a USB drive and run it like that. Obviously i am not that technical, but gave it a crack myself anyway as i love to learn new things.
      When this first didn't work it was time for some reading of the forums and help topics which got me going in the right direction. I then started hitting some problems with syslinux.exe file which would not create the USB boot disk properly and i eventually went through 3 USB disks before i found one that would successfully install the iso file 100%.
      From there i then hit the same problem nearly everyone on here had (with the DBAN bad sectors error) and i went through the forums and help sections again looking for answers and a solution.
      Everyone of you have helped me through this process without having to raise a support case or asking stupid questions on here which i know a lot of people including myself get annoyed at if they are already documented.
      It really is a matter of trial and error with some tasks and DBAN does not escape that process, but with the right help such as these forums, if you are willing to try and not give up you will get there. Sometimes it is just a matter of luck with what type of system you have and you can breeze through this...for the rest of us it is a matter of trial and error :)
      Honestly not everything is easy to find and maybe we can all help with some good topics for a getting started guide, troubleshooting & FAQ document which we can all source from one location on the DBAN site for all newbies to this process.
      It is just a thought anyway, because from all of everyones hard work (especially Darik) creating the code and posting problems/solutions before me has made my taks of wiping the hard drive eventually a lot easier than what it could have been without the forum!
      Thanks again and keep up the good work!

  • Anonymous

    Anonymous - 2010-07-13

    Had a similar problem. Tried 3 systems (one i7/x58, one core2duo, one amd quad with amd chipset). Every time i would get a non fatal error. In interactive mode it would show 4 extra hard drives with ???? next to them. It turns out it was seeing my flash card reader (has slots for 4 different types of flash). Solution was to unplug the reader and it worked fine after that.

  • Anonymous

    Anonymous - 2010-07-27

    Thanks for the post… Had the same problem with a built-in card reader on a laptop I'm selling.

  • Anonymous

    Anonymous - 2010-08-11

    I have used Dban for years - first time coming here.. and the first trick i learned using the program, disconnect everything other than the drive you want to wipe and the keyboard(if using a pc)

    fire it up- hit F4 - then select the method, i only use DoD Short(which is default, but i still go to method!)
    then wipe(F10) …
    never had a fatal crash error since following these steps..
    hope that helps..

  • Matthew B

    Matthew B - 2010-08-25


    You nailed it exactly! I was making myself crazy with this error. Then I realized that the built in SD Reader was showing as a ???? drive. Disabled the card reader in the BIOS… Fixed! Such an easy solution. This should be posted prominently in the help file or something.

    Thanks for pointing me in the right direction.

    Matthew B

  • gasmanp

    gasmanp - 2010-08-31

    I have same problem presumably due to card reader (???? appear in drive list), but the BIOS does not allow these to be disabled - there are no options for these (or indeed most other devices, crap BIOS by the look of it).
    Are there any options to deal with this in these circumstances?


  • C Saeger

    C Saeger - 2010-09-03

    This did not work for me.

    However, I adjusted my startup process and it started working correctly.
    I was originally booting up the PC, hitting F12 to get to the screen to select a boot device, and picking the USB drive from there.

    Instead of that, I went into the BIOS and moved the USB hard drive to the front of the list and rebooted.

    Non-fatal error went away, and the problem was fixed.

    - C

  • Sandy S

    Sandy S - 2010-09-20

    Okay, you can laugh all you want at me, but in the end please remember to be kind, because I am not a 'tech' person and I rely on the patients and kindness of those who are knowledable to  help me understand things in a non-technical way. So if there is anyone out there that can answer this question, I would 'greatly' appreciate it. Perhaps I should have started my own thread instead of squatting on this previous post, but I thought it was relevent enough to be a part of this post.

    Anyway, here is the problem. All three of my computers got infected with some nasty trojans and worms and I decided to format all of them using DBAN. The desktop format went flawlessly .. however I have run into a problem with my Gateway M-6337 laptop (this is the specs: I used DBAN dban-2.2.6_i586.iso burned on a CD. I placed a Lexar JumpDrive into the USB port right beside the DVD drive. I booted the computer and everything went according to plan … I chose method: RCMP TSSIT OPS-II (which I understand now was overkill just to get rid of viruses) … it took approximately 15 hours to complete. In the end this was the result:

    * ERROR /dev/sdb (process crash)
    * PASS ATA Disk WDC WD2500BEVS-2 01.8 232GB WD-WXH488660391

    So my question is this … 'because I have no idea what a /dev/sdb is, I just want to know if anyone can tell me is there any way that any kind of trojan / worm / virus, etc., could have survived because of this /dev/sdb crash … or am I safe to reinstall my software and carry on?

    Thank you so much for any and all advice and or information you can offer. I appreciate your time and best wishes to everyone who takes the time to help strangers with their problems just out of the kindness of their hearts.


  • Marin Trader

    Marin Trader - 2010-10-23

    I need to swap out my SATA WD320 harddrive with a replacement drive that Dell support has sent me.  Since my old drive still runs and boots up, I want to delete any files that are of a private nature.  Of couse we all know that delete and emply recycle bin don't do much (running Vista), so I ran an optimizing defrag (Auslogics) and thought that might do a decent job.  I was horrified to find out how much data was still undeletable when I ran WinUndelete's free undeleter.  So here I am attempting DBAN. 

    I have a simple Dell Inspiron 530 Q6600, 2.4ghz. system, 4gb, w/ a harddrive, dvd+/-rw and….. a 7in1 media card reader.  Ran DBAN using the autonuke command and the app came back w/ several versions of the "error/dev/s.." messages.  Ran into this post when doing a little research so I disconnected the media card reader from the motherboard.  Powered up the pc, booted from the cd I burned and viola.  DBAN is no 1 hour into the 4 hour process of deleting a 320gb Western Digital harddrive.  Of course I am going to check how "deleted" my files are when DBAN finishes, but I have a good feeling about the outcome. 

  • Rummages

    Rummages - 2010-11-09

    Also had same problem noted above, tried all of the BIOS disables with no luck. Read another post that said user switched to beta 2007042900 and autonuke worked. I tried the same thing and had no issues.

  • Anonymous

    Anonymous - 2011-03-16

    Got the process crash error, but due to a zip disk drive (totally retro).  Disconnected the drive and DBAN completed successfully.  Generally, if you have trouble disabling the offending drive in the BIOS, physically disconnecting the drive should work.

  • Gene Wood

    Gene Wood - 2011-06-28

    I was attempting to run DBAN on my Dell D430. I was booting from a USB Thumb / Flash drive that I'd put the DBAN image on using the Universal USB Installer on I kept getting the "non-fatal errors" message and DBAN would exit immediately. I tried changing all different settings in the BIOS. In the end the fix was to burn the DBAN iso to a DVD and dock my laptop in it's docking station and boot from the CD/DVD rom drive. This way DBAN came up and listed only one drive (not both the laptop hard drive and the USB flash drive). It worked fine booting from CD.

  • Todd

    Todd - 2011-07-11

    I was having the same process crash error due to my booting from a USB pen drive.  However, I couldn't boot from CD as I had stolen both IDE connections from the CD/DVD drives for IDE drives to be wiped.  I had two IDE, two SAS and one SATA drive, plus my USB Boot device.

    It was mentioned on another thread that the USB drive could be yanked out as DBAN is loading (the blue screen) in order to keep autonuke from blowing away your USB device.  It turns out that right after it finishes loading, it then starts taking inventory, "waiting for USB registrations" or something of that sort.  If I pulled it out before DBAN itself could discover the USB device, the list of drives presented were simply the drives I wanted to wipe with no indication that there ever was a USB device. 

    With DBAN not seeing the USB device (or not seeing a device that I would manually exclude), the wipe went off without a hitch.  So everybody that's saying to remove unneeded devices is correct - in this case you are able to remove a necessary device after it serves its purpose and before it causes the failure.

  • Anonymous

    Anonymous - 2011-08-06

    I owe many thanks to people for all the info on here, so thought i would post.

    after struggling with BOIS for a while (im no techie)                
    i just opened up the side of pc tower and unplugged the lead that goes to card reader.

    EASY PEASY, its now running fine.
    TRY IT.

  • avar

    avar - 2012-02-01

    wcoast1973,  removing the device after it serves it's purpos was bang on, I waited till it showed ready, then removed the usb key, after that point only the drive to wipe showed in the list to pick from, If I waited till the drive and the key were listed it would crash, Thanks,

  • Hemlig

    Hemlig - 2012-02-02

    I'm trying to run dban on my laptop and I get the following message:

    DBAN finished with non-fatal errors.
    This is usually caused by disks with bad sectors.
    Send the log file with all support requests.

    I can't disable any drivers in Bios, is the only possibility to open my laptop and
    disconnect the carddriver or do anyone have any suggestion?

  • Anonymous

    Anonymous - 2012-02-19

    Unplugging the card readers worked well. Thanks for the tip.

  • Anonymous

    Anonymous - 2012-03-23

    I was trying to wipe a unit with 3 drives while booting off usb.  I was selecting the 3 drives to wipe and leaving the usb I was booting from untouched.  Next I tried just wiping all 4, including the dban usb and presto, it is working like a charm.

    Not the best if I need to do a bunch in a row as I'll need to reformat my boot usb every time but . . .

  • Mike

    Mike - 2012-05-21

    Big thanks to rich1979 who mentioned the yanking usb flash drive tip. Just hit enter when it boots, then as soon as it says "detecting usb…" yank the flash drive. That way it doesn't show up and it won't crash. I was trying this on a laptop so none of the other tips were helping. The rest of you will have to like they said probably manually or via bios remove the card reader drives etc.

  • Bryan Dam

    Bryan Dam - 2012-07-19

    I was trying to run a similar setup as wcoast1973 but rather than yank the usb thumb drive I was booting off of I ran dban by entering dban nousb at the boot prompt.  The thumb drive wasn't detected and I was able to wipe the IDE drives just fine.

  • Glenn Olson

    Glenn Olson - 2012-07-21

    It was the card reader for me also!  That, and since I was booting from from USB pendrive, yanking out the USB before it was discovered.   Thanks wcoast1973!

  • Patrick Kelley

    Patrick Kelley - 2012-07-25

    This would be a good one for the DBAN FAQ I'm thinking. Another computer with built-in card readers that caused this excellent and usually very reliable program to fail without any useful error messages. Had to open up the computer and unplug the card reader, but easier than moving the hard drive to another box so I could erase it. Thanks all for the thread and fix!

  • Ravi B.

    Ravi B. - 2012-10-01

    The 'DBAN NOUSB" option just helped me to start wiping a Dell Latitude D630.

    I've created a bootable USBdrive with Universal USB installer, and pushed the DBAN2.2.7 image.
    But each time I tried to start the process I got a "Non-fatal error" quit, followed by the horrendous advertisement screen that just stays on there(lolwut).
    However, booting the image using the "nousb" resulted in a perfect start.

  • Stephen

    Stephen - 2012-10-03

    Removing the card reader or disabling it fixes this problem. I thought it was a bigger problem than that but turns out it was this simple. Thanks for the post, helped out a lot.

1 2 > >> (Page 1 of 2)

Log in to post a comment.