Unrecognized devices causing non-fatal error

  • Alex McIntosh

    Alex McIntosh - 2012-11-10

    Hi, when running DBAN from a CD the program loads, you get the usual menu interface. Press enter for the next screen and it lists 5 drives…. 4 of them say ' Unrecognizable device'  and the 5th on says 'ATA 298…etc' which is obviously the one and only hard disk. This is the one i want to nuke.

    When select the drive to wipe, the press F10 to start, screen goes black and i get the "Unrecognized devices causing non-fatal error….  *error/dev/sde
                                              /dev/sda         and of course you have to shut down the computer.

    So i THINK the problem stems from the fact that I am running a Dell Vostro 200 pc with USB ports for the keyboard and mouse etc:  TEAC USB HS-CF CARD  USB DEVICE
                          TEAC USB HS-MS CARD  USB DEVICE
                          TEAC USB HS-FD CARD  USB DEVICE
                          TEAC USB HS-xD/SM       USB DEVICE

    I am assuming these four USB ports are the " unrecognizable disks" and that they are causing the problem? Maybe not, but that's what I guessed!

    So, i went into the BIOS and disabled these USB ports, then also in BIOS selected primary boot as Boot From CD.
    All ok so far…. Problem is now the keyboard doesn't work so I can't use DBAN when I finally get there! :@  Ive read something about enabling legacy USB but there doesn't seem to be an option for this in my BIOS.

    Maybe this is not the cause of the non-fatal error, but from what I have read it may well be!

    Any thoughts welcome! Ta

  • Scott

    Scott - 2012-11-10

    Great synposis of what is going on.  Excellent.  When people give a good description and details, as in this example, it's much easier to diagnos problem and saves time and exchanging numerous emails.  You also did a good job in the things you tried - as I was reading, I was thinking of my response and then as I continued to read, you did the things I would have suggested.  Excellent you are using the forums before posting your question.  Possible solution:  You need your keyboard to work and it's not likely that DBAN will mistake a USB keyboard for a unrecognizable drive.  So, go back into BIOS and enable your keyboard and mouse.  Save changes.  Then reboot with DBAN disk in your CD drive.  If this suggestion works, please reply with a follow-up for others who may encounter same problem.  If this does not work, please post another reply so we can look at other options.  If you re-post, please mention what verion of DBAN you are using.  Hope this is helpful and good luck.

  • Alex McIntosh

    Alex McIntosh - 2012-11-10

    Thanks for the feedback!  Problem is turning the keyboard and mouse (all the usb ports) back on takes me back to where I started in the first place…. Just out of curiosity's sake I tried it again, and the same screen comes up… I got into DBAN when i had disabled the USB ports, i was just one "enter" away from being able to see whether those 4 " unrecognizable device"s are… But of course I couldnt use the Enter button lol

    I am using DBAN (or trying to!) as I'm selling my computer on to a friend of mine and godknows where it may end up! As far as Im aware you can do pretty much the same job as one full wipe with DBAN (which forensic experts have said is totally enough) with the Full Format option of a Windows Vista CD (writes 0000s over the whole disk), just wondering whether I need to be bothering with this as if i were to use a vista cd i'd fully format the drive with it, then afterwards re-install XP cos vistas just shite eye candy that doesnt work very well! Ha :D


  • Scott

    Scott - 2012-11-10

    The purpose of the forum is to help you use DBAN to wipe your drive.  I don't have  a suggestion or solution for you so maybe others will step in with one.  In the meantime, if you were to not wipe drive you would have files remaining on the drive even though it appears empty.  Format does not wipe a drive, it just creates a file system and divides the drive into blocks of data.  When you install Windows, it will overwrite a portion of the hard drive.  Generally, this is sufficient, but technically any recovery data software would be potentially capable of retrieving data from the drive.  It's just a really good idea to wipe the drive before installing windows.  This way you know the drive is clean and you have more guarantee that that the new installation of windows will be successful.

  • Alex McIntosh

    Alex McIntosh - 2012-11-12

    Well….Solved the problem! And I solved it by reading other threads on here :P

    The 4 unrecognisable  drives were the card reader on the front of the PC, not the USB drives. Now, being a relative noob i didnt know what a card reader was as such, the second I google imaged "card reader" I saw it and thought "There's the bugger!" IMO the quickest and easier way to fix this is to open up the computer (de-static yourself first on a radiator etc) then find the single wire that leads from the card reader to the motherboard… I just simply unplugged the wire from the motherboard and hey presto! The unrecognizable drives were gone, and DBAN worked first time! WOO Clean drive!  (I think physically unplugging the card reader was easier than fannying around in the BIOS looking for options!)

    Thanks very much for feedback etc on here!  :D

  • Frank

    Frank - 2013-01-27

    Had the exact same problem. Took the cover off and disconnected the card reader cable and dban ran without a hitch. Thanks for you work on this. I don't know why they don't specify the card reader as being a "drive" when no card is installed.

  • Mitch

    Mitch - 2013-01-30

    I'm pulling my hair out, someone help!! I'm positive I've disabled everything that could be possibly interfering but I'm still getting  Unrecognized Device appearing along with the hard drive I want to clear in the disks and Partitions list when opening DBAN. The card reader is clearly disabled in my device manager. The only devices I can see are my Hard drive, both C: and D: (which I believe are two seperate partitions within the one hard drive) and my CD/DVD drive. Could it be the empty D: partition on my hard drive that shows as the unrecognized device? I have an Acer Aspire 5735. Can anyone shed any light on this for me?

  • Frank

    Frank - 2013-01-30

    Did you try opening the PC and physically disconnecting the card reader cable not just in the bios?

  • redstring

    redstring - 2013-02-06

    I'm in the same boat, let me know if anyone has any ideas!

    On an Optiplex 320 I've:
    - Unplugged everything aside from HDD to be wiped and the optical drive.  (There is no card reader)
    - Disabled all unused SATA/PATA drives in the BIOS.
    - Disabled the floppy from the boot devices (it already was 'not found' because there isn't one.  I disabled it just to be sure)
    - Toggled different BIOS settings such as moving the CD drive to be 1st booted and booting straight to DBAN instead of going through Boot menu.
    - Used different menu items such as autonuke, noverify, nofloppy, dban nousb.    When pressing Enter to go into interactive mode it takes me to the same screen - DBAN has finished, may be bad sectors, etc…

    This is happening with multiple Optiplex 320s using multiple DBAN cds that have been working for months now.  I can't figure out what is causing it…

  • redstring

    redstring - 2013-02-07

    Follow up to my post above:

    I've switched to DBAN version 2.2.7 and the issues have cleared up.


Log in to post a comment.