DBAN Error - "PCI (sysfs)"

1 2 3 > >> (Page 1 of 3)
  • Sarah Sarah

    Sarah Sarah - 2010-05-31

    Hi there,

    I'm trying to run DBAN from a CD on an old laptop (HP Pavilion dv2125nr).  Got the CD to load fine, used the autonuke feature, and it loaded DBAN.  It got through "waiting for USB devices to register…done" and then displays "PCI (sysfs).  At that point, the program just hangs.  I tried restarting DBAN and the same thing happened, and then I left it overnight, but it never moved on.


  • Kevinul

    Kevinul - 2010-06-07

    I to have this problem, and yet there seems to be no solution from anyone.

  • Allan

    Allan - 2010-06-09

    From the message (sysfs) I assumed it was something with the file system (big stretch there…) and from that I went on a hunt in my BIOS for anything regarding the file system that would trip up the program.  On my Dell E5500 I have a external SATA (eSATA) port that by default is enabled.  I turned that off thinking it would help but had the same issue.  So I looked through the BIOS for something else and I also have a "Media Card" reader that can be disabled.  I thought "Hrm…that media card reader comes up as a drive in windows….maybe it's getting stuck on that."  So I turned that off and DBAN ran fine.  After it cleared my HD I went back into the BIOS and turned the eSATA back on. 

    So look in your BIOS for any card readers that might be detected as drives and turn them off if you can.  If you CANT turn them off I would try throwing some media in them and maybe they will be detected properly and let you get by this issue.


  • Darik Horn

    Darik Horn - 2010-06-15

    DBAN is hanging on the lshw hardware detection routine.  Knowing that it was caused by a media card reader is helpful. 

  • savsayre

    savsayre - 2010-06-16

    i did what allan said and dban works fine for me now
    thanks so much!

  • John Neidig

    John Neidig - 2010-08-31

    You have to go into the BIOS and disable media card reader

  • Anonymous

    Anonymous - 2010-09-04

    i am having the exact same problem and i also have a card reader i would like to disable.  Could someone please tell me exactly how to disable it in BIOS?  I go into f10 and it will allow me to change boot order but i do not see enabled/disabled drives or how to change them.. 

  • Allan

    Allan - 2010-09-04

    It wouldn't be anything with the boot order.  Try "DEL" or F2 or F1 at boot  up to get into your BIOS. 

    Worst case open up your computer and see if the card reader has a physical cable that plugs into the motherboard.  If so disconnect it.

  • nikopico

    nikopico - 2010-10-07

    Yes, will somebody please tell HOW to find, identify and disable the card reader in a laptop.

    I have just found this thread - after I posted about exactly this same problem. -  PCI (sysfs).

    I know  how to get into the BIOS but cant see anything that identifies a card reader.

  • Allan

    Allan - 2010-10-07

    It might be listed as media reader, card reader, SD reader, MMC reader.  Honestly it could be a whole bunch of stuff, just have to look through the bios for something that makes sense, turn it off, and try again.

    Or like I mentioned above try putting something in it and test it that way (I didn't try this but I think it might work).


  • Ivan Dobrianov

    Ivan Dobrianov - 2010-10-10

    I gave up trying to use DBAN on my Lenovo T61p laptop!

    Fortunately, burning a live Linux, such as Knoppix, on a DVD/CD and then just doing:

    shred -fvz -n 3 /dev/sda

    does the trick for me. The above command does 3 passes of random data overwrite and a final pass with zeroes. The only thing is that you have to figure out the exact name of your hard disk - "sda" on my machine. See http://www.engadget.com/2005/03/15/how-to-erase-old-hard-disks/ for more info.

    Hope this helps!

  • nikopico

    nikopico - 2010-10-14

    Well I cant do a thing with my Acer with XP.

    I identified  card-reader and removed it from boot order (Shift 1 doesnt do anything - it says it should disable it but doesnt -) but even so DBAN still  things hangs with   ""PCI (sysfs)."

    But now I see that it says - "Error receiving uevent message. No buffer spaca available".    Is that relevant?

  • Anonymous

    Anonymous - 2010-11-04

    Hi there, I'm having the same issue with the "PCI (sysfs)" message and DBAN just hanging there, I'll give the media card reader a shot by loading a card into the slot and post the results so people have a difinative answer to that part of the question.

    If that does not work first try I'll look for it in the BIOS or go for the jugular and crack the case and find a power cord to the card reader.

    Has anyone else had this same error message, and found that it was some other issue than the media card reader, just out of curiosity?

    Initially I had wanted to reformat my hard drive, due to too many disc error messages, but a friend turned me on to the idea of using DBAN to do a full disc wipe then starting from scratch, assuming the had drive had become infected/corrupt?

    I'll check back for more info on this later in the day, and post my results when I get it to work on my end.

  • Anonymous

    Anonymous - 2010-11-05

    Ok well I tried putting a card in the media card reader slot, same results PCI (sysfs) and it hangs there.

    So I went into the BIOS and shut off the Card Reader in the boot options, now i get this:
    "Error receiving event message. No buffer space available".

    I just want to WIPE this HD of everything and put a clean install of Windows 7 on it, anyone got any ohter suggestions?

  • Allan

    Allan - 2010-11-05

    If its your drive and you're reusing it then just install over it.  Start up the Win7 setup, at the drive selection/partition screen select advanced.  Delete any partitions listed so it just says "Unpartitioned Space" or whatever and then install.

    DBAN is really more for cleaning sensitive data off of a drive before disposing of or selling, if your just reusing it then your going through a lot of extra trouble for no reason.


  • Anonymous

    Anonymous - 2010-11-05

    Hi Allan,

    Thanks for the reply, my bigger issue was that everytime I boot uo my Windows 7, Dell Studio XPS, I get the stupid preboot screen with the message "one of your drives needs to be checked for consistency…" and it is getting old, so I wanted to wipe the drive clean to see if it was a "software bug" or a hardware issue and I neede to look at replacing the HD on the laptop.

    But if you have any other suggestions for this, I'm wide open!

    Thanks again

  • Gordo

    Gordo - 2010-11-12

    For those looking for specific directions, maybe my experience can help. I am not very technical but figured this out, especially with help above from the member who discovered the media card issue.

    Anyway, am wiping a Dell Inspiron E1505. Had the exact same issue, where it hung on PCI (sysfs). I rebooted, hit F12 to get to the boot menu. An option there says BIOS. Select that. I had to go down a list of options. In my case, it was the one under the boot sequence. Can't remember the exact name, but it had 2 options. One was the LAN card (maybe it was the internal NIC) and the other was the 'media card.' It also mentioned the 1394.

    I disabled the option for the media card, re-started the DBAN and it is running like all the other step by step instructions I have found. I might add, researching my initial issues, stumbling upon DBAN, looking into that and getting it to run right has taken me many hours over about 3 days. I ended up at this point because my laptop suddenly went into 'other user' mode and lots of other strange behavior. I ran Malwarebytes and Avast, and it didn't take care of the issue. So want to wipe it clean and am going to put Win7 on.

  • David Tsoi

    David Tsoi - 2010-11-16

    I'm having the same hang up issue. DBAN boots to the main screen but trying to enter the interactive mode program trips up on the PCI (sysfs). I've tried to dissable what might be causing the hang up with no luck. Currently trying to secure format a Dell Studio XPS 1640 laptop w/ Phoenix BIOS A14. I can't find any card reader listed under the advanced or boot list so I can disable it. any suggestions?

  • glsmas

    glsmas - 2010-11-26

    I had the same problem - PCI(sys) would come up and it would just hang there.

    Use Dan's advice.

    In setup I disabled not only the floppy drive in the boot sequence (also NIC which showed up as number 5 in the list), but also under "Onboard Devices" I disabled what I figured was a media reader. It didn't say "media reader" exactly, but as you go through the list it becomes apparent.

    In any event, try it -- worked for me.

  • Dennis N Brown

    Dennis N Brown - 2010-12-05

    Machine: Lenovo T61p

    I was also having the hang at "PCI (sysfs)" on my laptop and I was able to resolve the problem by updating the BIOS to disable the card reader slot.

    On this BIOS the settings under "Security->I/O Port Access", I disabled "Memory Card Slot" and "Smart Card Slot". 

    I then got the "Error receiving event message. No buffer space available" message, but everything worked fine.

  • Johnny Trev

    Johnny Trev - 2010-12-16

    If you're having trouble booting DBAN, then you can give "nwipe" a go - it's exactly the same wiping tool (it's a fork of DBAN), but is a standalone program that will run in any Linux distribution.

    It's included in Parted Magic - just download the latest ISO and go to 'nwipe' in the menu.

  • HansE

    HansE - 2010-12-23

    I also spent several (part-time) days attempting first the DBAN v1.0.7 and then the v2.2.6 (beta).  All options failed, and to be honest I was often away from the system so I missed the displays.  Eventually with the Interactive Mode I noticed this same hang on PCI and sysfs and subsequently located your fix.  Opening the BIOS ( for my HP laptop) and setting the Media Card Reader to "Disabled" was the exact trick.  Note that changing the Boot Order is not the same thing, so you must disable the card not just move the seek order.

    Running fine now, will make a note of this on the CD itself, but someone should post this to the FAQ as a known issue for Devices.

  • Jason Coe

    Jason Coe - 2011-01-17

    Post #3 solved it for me.  I turned the media card off in the BIOS, and DBAN worked!  Thanks a lot!!!

  •  Dannl

    Dannl - 2011-01-25

    I got it to work on my Dell Studio 1735 by using the 2.0 2007-04-29 beta version. I don't really want to say it was worth the hassle, but it was. Everything is clean as a whistle.

  • walkerman

    walkerman - 2011-02-04

    "PCI (SYSFS)" message stuck overnight.  In the BIOS/setup I deleted all drives except HDD and CD drives with no luck, the message still stuck.  Pulled the cable off of the media reader but still had the error.  D/L'ed the old 2.7 version and it worked great.  It would have saved me a couple of hours time if I had done that at the start.

1 2 3 > >> (Page 1 of 3)

Log in to post a comment.