Shared Mailbox

Help
2011-07-08
2016-05-25
  • Christophe Humbert

    Hello,

    I am on Exchange 2003 and with my colleagues we are sharing a mailbox which we can access with our own credentials.
    Is it supported and if yes what will be the configuration settings to do.
    I am on Linux with TB 5.0 and latest stable of davmail.

    Thanks a lot

     
  • Tsukasa Karuna

    Tsukasa Karuna - 2011-07-08

    I've got the same question here too. Our organization shares a department wide mailbox which is accessed through OWA like so: http://company.com/owa/mailbox@company.com

    The login credentials for our regular self-owned mailboxes allow access into this box. How do I set up either DavMail or the IMAP client i'm using (alpine) to access this other mailbox?

     
  • Mickael Guessant

    This is untested but you can try to set mailbox path to:
    /users/mailbox@company.com
    in IMAP settings

     
  • Tsukasa Karuna

    Tsukasa Karuna - 2011-07-11

    Tried, doesn't work unfortunately. Alpine just comes back with a blank folder list.

     
  • Mickael Guessant

    Can you please provide a log file at my private address mguessan@free.fr ?

     
  • Christophe Humbert

    Hello,

    I have tested and this only duplicate my personal inbox :(

    Do you want a log file?

    Kind Regards

     
  • Mickael Guessant

    Definitely

     
  • iiioiooo

    iiioiooo - 2012-04-24

    hi, any news on this topic?
    did you manage to get it work?
    i am having exactly the same problem

    thank you!

     
  • iiioiooo

    iiioiooo - 2012-04-24

    I actually managed to get it work:

    1) you login in your OWA webmail with your normal email address
    2) click on your name in the right corner
    3) choose the desired mailbox
    4) add a rule clicking on options below your name in the right corner
    5) rule: forward all messages to your.name@yourcompany.com
    6) log out or stay logged in, it'll work

    DONE!

     
  • Anonymous - 2012-05-02

    I managed to get this working without the need for a forwarding rule.

    Using Thunderbird I created an additional imap account pointing to my davmail server. 

    To get the correct username info I logged into webmail and accessed the shared mailbox I wanted to add to Thunderbird.  I copied the username for the shared mailbox from the address bar ( in my case, the URL read:
    https://webmail.<domain>/owa/<shared-mailbox-username>/ )

    This username was in the form of username.username@domain (not sure if this is standard)

    I added the following as my username in the imap settings for the new account in thunderbird:

    <domain>\&lt;my-userid>\&lt;shared-mailbox-username>

    and used my lan password to authenticate.

    I was then able to access the shared folder from thunderbird

     
  • Mickael Guessant

    Doc updated, thanks for your feedback

     
  • Lakthinda

    Lakthinda - 2013-08-30

    Im Using Thunderbird 17.0.8, Exchange server 2007, Davmail 4.3.3.

    I tried above configurations, but couldn't connect to Exchange server shared mailbox through DavMail.

    Username: <domain>\<NT userID>\<Shared mailbox username>
    Password: NT password

    Has anyone tried this recently?

     
  • Mickael Guessant

    Did you try to set base path to /users/<Shared mailbox="" email="" address=""> ?

     
  • vitaminx

    vitaminx - 2013-10-25

    Hi,

    I tried to access my company's shared mailbox like this:

    I've added a new IMAP mailbox to Thunderbird with User Name:

    <domain>\<user>\<shared_mailbox@company.net>
    

    All the folders appear and everything looks fine at first, but I cannot move any mail to subfolders, e.g. trying to move a mail from 'Inbox' to 'Inbox\WPP' results in an error like this:

    "The current operation on 'Inbox' did not succeed. The mail server for account <shared_mailbox@company.net> responded: Folder "Inbox\WPP" not found."
    

    I also notice that this mailbox shows an additional grey subfolder in Thunderbird with this path:

    /users -> <shared_mailbox@company.net> -> INBOX
    

    This inbox contains an exact copy of the mails from the real Inbox, but it doesnt have any subfolders.

    In another attempt I've changed the setting to this:

    User Name: <domain>\<user>
    IMAP server directory: users/<shared_mailbox@company.net>
    

    This seems to work just perfect, but now I cannot configure it together with my private mailbox in Thunderbird.

    I have my private mailbox already set to username

    <domain>\<user>
    

    so Thunderbird complains now with:

    "An account with that user name and server name already exists. Please enter a different user name and/or server name."
    

    Any idea how to set up a shared mailbox together with a personal mailbox which share the same credentials?

    Regards,
    vitaminx

     
    Last edit: vitaminx 2013-10-25
    • Paul Barker

      Paul Barker - 2014-06-03

      Thanks vitaminx, Had the same problems but your second option does not work at all, it only displays my Inbox not the shared.

      User Name: <domain>\<user>
      IMAP server directory: users/<shared_mailbox@company.net>
      

      Exchange 2010 SP3 OWA and EWS enabled.

      Any thoughts??

      Paul

       
  • Mickael Guessant

    Note that folder separator is /, not \

     
  • vitaminx

    vitaminx - 2013-10-28

    Hi, I've tried both slashes, but it doesn't seem to make any difference here.

    I've also played around with IMAP settings in in "Advanced Account Settings" of Thunderbird, e.g. server directory and namespaces, but I'm just guessing - I'm not really sure what to put there.

     
  • Maris

    Maris - 2014-06-19

    Hi. I set up private account to access excahnge 2010. And it worked like charm thanks to DAVMAIL. But when I try on Thunderbird add another existing email account (shared by other users) I can not. I tried to write a lot of varitions under usename:
    shared.user.name
    private.user shared.user.name
    domain private.user shared.user.name

    I can login into owa from web into my personal. And also open on web shared mailbox.

    Any ideas?

     
    Last edit: Maris 2014-06-19
  • Mickael Guessant

    Did you try:
    <domain>\<user>\<shared_mailbox@company.net>

    as IMAP user name ?

     
  • Maris

    Maris - 2014-06-26

    HI.
    Added screenshot.
    I added under username now:
    \<user>\<ma.shared@huhu.com> still did not worked out.

     
  • Mickael Guessant

    Sorry, my comment was incomplete, you need the domain prefix:

    <domain>\<user>\<ma.shared@huhu.com>

     
  • Maris

    Maris - 2014-07-10

    Hi.
    So as USERNAME I added: (on latest Linux Thunderbird)
    <domain-huhu.net>\<ma.personal>\<ma.shared@huhu.com>

    Result:
    1. Asked for certificate. (added as trusted)
    2. But DavMail icon on top right corner said: Authentication failed: invalid user or password.

    so still not working.

     
  • Mickael Guessant

    Ok, next try: domain-huhu.net is your full DNS domain name, not the short Netbios name expected by Exchange

     
  • Lucas Magasweran

    The short Windows domain (e.g. DOMAIN and not domain.example.com) worked in my environment.

    Thanks for figuring this out and documenting it!

    By the way, I did not find mention of how to do this in the updated documentation. Only the OS X had a brief mention of shared mailboxes (http://davmail.sourceforge.net/osximapmailsetup.html).

     
  • Cristiano Guadagnino

    Hi all, I am trying to switch from Thunderbird to KMail.

    I can configure my main mailbox using DavMail without problems, but I haven't been able to configure shared mailboxes.

    KMail does not have an "advanced" section in the IMAP configuration like THunderbird has, so I tried using the different username trick.

    My windows domain username is XYZ\U1234567 where XYZ is the domain and U1234567 is my username (both are fake, obviously).

    My shared mailbox is called (fake) shmbox and the OWA url shows it as shmbox@company.it.

    So I put this username in KMail account configuration:

    XYZ\U1234567\shmbox@company.it

    but KMail throws this error message:

    Login failed, server replied: A000001 NO LOGIN failed

    Have you ever tried using KMail with this kind of setup?
    Do you know of any workaround?

    Thank you in advance
    Cris

     
    Last edit: Cristiano Guadagnino 2016-05-25

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks