#444 The Debian package misses a requisite package

v3.9.8
closed-invalid
nobody
None
5
2012-07-17
2012-06-27
No

On my fresh Debian unstable I seem to have missed a requisite JNI package on which the headrev davmail depends,

$ sudo update-alternatives --config java

$ cd davmail
$ ant clean
$ svn up
$ ant
$ sudo dpkg -i dist/davmail_3.9.8-1972-1_all.deb

$ /usr/bin/davmail
Exception in thread "SWT" java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
no swt-cairo-gtk-3832 in java.library.path
no swt-cairo-gtk in java.library.path
Can't load library: /usr/lib/jni/libswt-cairo-gtk-3832.so
Can't load library: /usr/lib/jni/libswt-cairo-gtk.so
Can't load library: /home/ilguiz/.swt/lib/linux/x86/libswt-cairo-gtk-3832.so
Can't load library: /home/ilguiz/.swt/lib/linux/x86/libswt-cairo-gtk.so

at org.eclipse.swt.internal.Library.loadLibrary(Library.java:335)
at org.eclipse.swt.internal.Library.loadLibrary(Library.java:240)
at org.eclipse.swt.internal.cairo.Cairo.<clinit>(Cairo.java:27)
at org.eclipse.swt.graphics.Image.init(Image.java:1322)
at org.eclipse.swt.graphics.Image.<init>(Image.java:629)
at davmail.ui.tray.SwtGatewayTray.loadSwtImage(SwtGatewayTray.java:163)
at davmail.ui.tray.SwtGatewayTray$5.run(SwtGatewayTray.java:206)

$ sudo apt-file update

$ sudo apt-file search "swt" | grep cairo
libswt-cairo-gtk-3-jni: /usr/lib/jni/libswt-cairo-gtk-3832.so
libswt-cairo-gtk-3-jni: /usr/share/doc/libswt-cairo-gtk-3-jni/changelog.Debian.gz
libswt-cairo-gtk-3-jni: /usr/share/doc/libswt-cairo-gtk-3-jni/copyright

$ sudo apt-get install libswt-cairo-gtk-3-jni

$ /usr/bin/davmail

Discussion

  • Ilguiz Latypov

    Ilguiz Latypov - 2012-06-27

    My Debian unstable upgrade caused a lot of grief this afternoon. Starting davmail ends with various crashes such as one in DBus,

    (SWT:24053): GConf-WARNING **: Got Disconnected from DBus.
    C [libdbus-1.so.3+0x28e34]
    [error occurred during error reporting (printing problematic frame), id 0xb]

    or another crash due to memory corruption in libdbus,

    *** glibc detected *** java: malloc(): memory corruption: 0x097f0e88 ***
    ======= Backtrace: =========
    #
    # A fatal error has been detected by the Java Runtime Environment:
    #
    # SIGSEGV (0xb) at pc=0xb768e0d3, pid=24117, tid=2306874224
    #
    # JRE version: 6.0_24-b24
    # Java VM: OpenJDK Server VM (20.0-b12 mixed mode linux-x86 )
    # Derivative: IcedTea6 1.11.3
    # Distribution: Debian GNU/Linux unstable (sid), package 6b24-1.11.3-2
    # Problematic frame:
    # /lib/i386-linux-gnu/i686/cmov/libc.so.6(+0x711d4)[0xb75e91d4]
    C [libc.so.6+0x1160d3]/lib/i386-linux-gnu/i686/cmov/libc.so.6(__libc_calloc+0xab)[0xb75ea54b]
    getaliasbyname_r+0x70d3
    #
    /lib/i386-linux-gnu/libdbus-1.so.3(dbus_malloc0+0x29)[0x891288a9]
    ======= Memory map: ========
    # An error report file with more information is saved as:
    # /home/ilguiz/davmail/hs_err_pid24117.log
    [..]

     
  • Mickael Guessant

    On missing dependency: the native dependency should be provided by SWT package, not DavMail

    On Gconf crash: try to disable use system proxies in DavMail settings

     
  • Ilguiz Latypov

    Ilguiz Latypov - 2012-06-28

    I could work around the crash by changing the Java runtime to Open JDK 1.7,

    sudo update-alternatives --config java

    It is possible that davmail could compile with Open JDK 1.7
    and that its build system prevents higher version numbers by mistake.

    Changing the Java runtime might hide the defect. I did not
    investigate the root cause of the defect. Perhaps, the libraries shown
    by the traces only receive a corruption from JDK.

    Thanks for pointing to the missing dependency source.

     
  • Ilguiz Latypov

    Ilguiz Latypov - 2012-06-28
    • status: open --> closed
     
  • Ilguiz Latypov

    Ilguiz Latypov - 2012-06-28

    I just tried disabling the use of system proxies and davmail worked with Open JDK 1.6 without a crash. I will add this detail to my Debian bug report 679319. Thanks.

     
  • Ilguiz Latypov

    Ilguiz Latypov - 2012-06-28
    • status: closed --> open
     
  • Mickael Guessant

    OpenJDK bug

     
  • Mickael Guessant

    • status: open --> closed-invalid
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks