error moving directories from davfs2

Help
deldar
2006-07-12
2013-04-16
  • deldar

    deldar - 2006-07-12

    Hi,

      I've setup a dav directory with apache2 and everything seems to work with davfs2 (I can browse the files, edit them ok).
      But when I move a directory from the davfs2 filesystem to the local filesystem, it works but the directory remains (empty) on the source davfs2 filesystem ... and I get this error message (translated from french message, this might not be the original words):

    mv /mnt/mydavmount/fold /home/me/puitthere/
    mv: inter peripheral moving error: `/mnt/mydavmount/fold' to `/home/me/puitthere/'; unable to destroy the target: is a directory

      Is there any way to prevent this ? Does this comes from the configuration of the server of the client ? I tried to mount a test drive the same way I did for my own (on test.webdav.org) and I get the exact same error so I guess this comes from the client ... I also tested using konqueror builtin webdav://... function, and I have no trouble this way (but I'd better use davfs2 if I want to edit file "in place").

       Any help welcome,

    Best,

    Deldar

     
    • Werner Baumann

      Werner Baumann - 2006-07-13

      Hello Deldar,

      I could not reproduce this bug when moving a directory from a dav-mount to a local file system. But I found problems the  other way round, moving a directory from a local file system to a dav-mount.

      A possible reason for both might be that the application or coda get confused, because they are not allowed to change attributes of a file or a dirctory. This is a security restriction in davfs2-0.2.x.

      But I could not yet definitely identify the reason.

      A possible work around: Use 'cp -r' and 'rm -r'. I found no problems with this combination.

      Another possible solution: Use davfs2-1.0.2. This can handle unix permissions and does not have this security restrictions. I did not find problems with the move of directories. But davfs2-1.0.2 is still beta-code and you might find other bugs (I would be happy if you found the other bugs I did not find yet).

      You might help debugging davfs2-0.2.x:
      Configure davfs2 with option --with-debug and build the package. Now there will be a lot of debug messages in your log files. You could send me this log entries associated with the buggy behaviour. If you do so, please first check the log files: There will be lines containing your credentials (at startup). You should remove this lines before you send the logs to me.

      Greetings
      Werner

       
      • deldar

        deldar - 2006-07-17

        Hi Werner,

           Actually, further testing indicated that a right problem on the server side was responsible for the problem I described ... sorry for the "false track" and thank you anyway for your quick support ...

           Everything seems ok now except from the fact that moving directories with konqueror from the dav drive to my local filesystem moves everything correctly but "leaves" a directory on the source drive ... it seems to be rectreacted automatically  ... but I'll try to investigate that more further.

        Best,

        Deldar

         

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks