Segmentation fault

  • giffyd

    giffyd - 2007-04-25


    I'm trying to mount my WebDAV folder using davfs. When I try to mount it I get the following error message:

    $ mount.davfs http://localhost:8080 /mnt/webdav/       
    Please enter the username to authenticate with server http://localhost:8080 or hit enter for none.
    Username: xxxxxx
    Please enter the password to authenticate user system with server http://localhost:8080 or hit enter for none.
    Password: xxxxxx
    Segmentation fault

    If I try and mount like this:
    $ mount -t davfs http://localhost:8080 /mnt/webdav
    No error messages appear, however when I go into /mnt/webdav I don't see any files and if I run the "mount" command to view active mounts, I don't see an entry for the webdav folder.

    I've successfully logged into the webdav folder using cadaver. Unfortunatly cadaver doesn't fit the requirements of the project.

    I'm using davfs2-1.2.0

    Any help would be greatly appreciated.


    • Mihai

      Mihai - 2007-04-25

      The same issue with davfs2-1.2.0 compiled on an RHEL4 and on SUSE 10.1; Required neon, fuse and coda are there but silently is not working; no error messages (compiled with --enable-debug)

      Any clue much appreciated

    • Werner Baumann

      Werner Baumann - 2007-04-25

      There is a Null-pointer bug in 1.2.0 that is fixed in CVS and there will be a bug-fixed release these days. But I am not sure whether this is the same error.

      So please configure with option --enable-debug, compile and install. There will be a lot of debug messages in one of your log files. Please send this messages together with command line and error messages, to see where the error occurs:

      When there is no error message, but mount.davfs does not work: is the mount.davfs process still running (ps ax)?



Log in to post a comment.