Anonymous - 2002-01-17

I compiled davfs 0.2.3 against kernel 2.4.17, got the following error... is it a kernel source problem or davfs source problem? Also tried kernel 2.4.7 comes with Redhat 7.2, same error.

...
Making all in davfs
make[2]: Entering directory `/tmp/davfs-0.2.3/davfs'
gcc   -c -o dir.o -O3 -Wall -DMODULE -D__KERNEL__ -DLINUX -fomit-frame-pointer -I/usr/src/linux/include dir.c
In file included from /usr/src/linux/include/linux/irq.h:69,
                 from /usr/include/asm/hardirq.h:6,
                 from /usr/src/linux/include/linux/interrupt.h:45,
                 from /usr/include/asm/highmem.h:25,
                 from /usr/src/linux/include/linux/highmem.h:11,
                 from /usr/src/linux/include/linux/pagemap.h:16,
                 from /usr/src/linux/include/linux/locks.h:8,
                 from davfs.h:13,
                 from dir.c:16:
/usr/include/asm/hw_irq.h:186: conflicting types for `prof_shift'
/usr/src/linux/include/linux/sched.h:581: previous declaration of `prof_shift'
/usr/include/asm/hw_irq.h: In function `x86_do_profile':
/usr/include/asm/hw_irq.h:203: `prof_pid' undeclared (first use in this function)
/usr/include/asm/hw_irq.h:203: (Each undeclared identifier is reported only once
/usr/include/asm/hw_irq.h:203: for each function it appears in.)
make[2]: *** [dir.o] Error 1
make[2]: Leaving directory `/tmp/davfs-0.2.3/davfs'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/davfs-0.2.3'
make: *** [all-recursive-am] Error 2
...