fstab does not allow you to mount...

H. Palme
  • H. Palme

    H. Palme - 2006-02-08


    I get the message mentioned in the subject when trying to mount as a non-root user.

    My fstab entry is

    https://our-bscw-server/bscw/bscw.cgi/:palme /mnt/BSCW/ davfs    user,noauto    0    0

    The user trying to mount is the owner of the mount point.

    root can mount without problems!!

    What could be wrong?

    Thanks in advance...

    • Werner Baumann

      Werner Baumann - 2006-02-11

      Don't use trailing slash with the mount point in fstab. Just '/mnt/BSCW'. The trailing slash will not appear in /proc/mounts and this will give problems when unmounting.

      When mounting as non-root user, you must *not* give any options on the command line. Just 'mount /mnt/BSCW'. davfs2 will not allow any differences between command line and fstab for ordinary users, as this would undermine the control by root.

      If there are still problems, I at least need:
      full text of fstab-entry
      full text of command line
      full text of davfs2 output


    • H. Palme

      H. Palme - 2006-02-13

      Thanks. The trailing slash was the problem -- it works now.

      But it works sloooowly. When using http (no SSL), it works a littlke bit faster. Is this a general problem or our server (BSCW 4.3)?
      (Over the web it works fine and also the KDE webdavs:// protocol works faster!)


    • H. Palme

      H. Palme - 2006-02-14

      Hmm... mounting and reading works fine, but when I try to copy files to the file system, empty files arrive. Is there any known bug concerning this?


    • Werner Baumann

      Werner Baumann - 2006-02-15

      davfs2 is slow because it translates every file system call of applications into a HTTP request. Applications build for WebDAV can take care of this but davfs2 works with any application. Most of them think file system calls are cheap.
      To overcome this I am working on extended caching.

      Empty files:
      Please send a more detailed example, including input and output from command line, so I can better understand what's the problem.


      • H. Palme

        H. Palme - 2006-02-16

        Hmm... very strange...

        That's what I did:

        - copy files to davfs
          => they have been well readable on the davfs
        - deleted the files with BSCW
        - tried to copy again
          => Error message
          tacitus [12:16] ~/Tests/BSCW>cp * /mnt/BSCW/Test/
          cp: reguläre Datei ,,/mnt/BSCW/Test/test_Word.doc" kann nicht angelegt werden: Datei oder Verzeichnis nicht gefunden

        - copied with Konqueror/webdav
          => files arrives but on davfs shown as zero length
        - removed on davfs
        - copied again on davfs
          => OK

        (I hope I correctly reconstructed what I did...)

        That's what the mount command shows:

        http://Our-BSCW-Server/bscw/bscw.cgi/:palme on /mnt/BSCW type coda (rw,nodev,noexec,nosuid,device=/dev/davfs0,user=palme)


    • Werner Baumann

      Werner Baumann - 2006-02-22


      I could reproduce the error.
      It is a bug in davfs2. Will take some time to fix it.


    • Werner Baumann

      Werner Baumann - 2006-02-27

      I think the bug is fixed no.
      You may get the bug fixed code from CVS an compile.
      But there will also be a new release soon.


      • H. Palme

        H. Palme - 2006-03-21

        I just installed the Debian package davfs2  0.2.8-1sarge1 from your site. After setting /usr/lib/mount.davfs-2.* to "setuid" I could mount our BSCW file system as a normal user and the files showed their real contents (sorry, I had no time to test more for now).

        A possible improvement:

        When being installed, the package should ask wether to set the two files "setuid" or not, accompanied by the appropriate warnings. Other packages do so too. This is a real stumbling block, I think.

        Thanks and greetings, Hubert


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks