#88 davfs2-0.2.9 ./configure problem

closed
None
5
2008-11-24
2008-11-24
No

Using davfs2-0.2.9 from tarball.

checking for neon-config... /usr/local/bin/neon-config
checking linking against neon... yes
configure: incompatible neon library version 0.28.3: wanted 0.24 25
configure: error: could not find neon
[root@host davfs2-0.2.9]#

Discussion

  • Werner Baumann

    Werner Baumann - 2008-11-24
    • assigned_to: nobody --> wbaumann
     
  • Werner Baumann

    Werner Baumann - 2008-11-24

    davfs2 0.2.9 was released two years ago when neon 0.25 was the latest release of neon.
    If you want (or need) to use this old version you might want to install neon 0.25 too. It should not cause any trouble to install different versions of neon.

    As the interface of neon has changed, updating davfs2 v0 to the latest version of neon will probably require to change several calls to neon functions, with a lot of "#if ... #else ..".

    Is there any reason to use this old version of davfs2 and not to install an old version of neon that would justify this effort?

    Cheers
    Werner

     
  • ntalkrescued

    ntalkrescued - 2008-11-24
    • status: open --> closed
     
  • ntalkrescued

    ntalkrescued - 2008-11-24

    Thanks for your comments, please close this issue.

    Looks like I downloaded the old version(thanks for pointing this out), normally I download the latest versions. I think I must have scrolled right past the links up the top thinking that the download was below the changelog.

     

Log in to post a comment.