#4 Improper umount puts fs in a bad state

v0.0.1
closed
5
2001-12-21
2001-07-03
Muthu Kumar
No

The problem is if the "dav" mount point is not
umounted before the "DAV" server goes down, the
commands such as "ls" fail to work on /mnt. Typing
"ls /mnt" from /mnt or from anywhere else does
nothing.The ls just hangs.

However, if you had different console window open and
if debug was enabled, you will see the message
"http://blah:No route to host.

Steps to reproduce:

* use two different machines. one running dav server
and the other one is client.

1. Change to /mnt
2. Create and a mount point called "dav" and mount it.
3. Change to /mnt/dav
3. shutdown the DAV server
4. Type ls .. from /mnt/dav
5. you will see some weired behavior or ls will just
hang. Ctrl-C to come out of it.
5. Change to /
6. type ls /mnt
7. you will see a weired behavior or ls will just hang.

if you had different console window open and you will
notice "http://your dav server addrss: no route to
host.

Please email me if you need further information.

Muthu

Discussion

  • Muthu Kumar

    Muthu Kumar - 2001-07-03

    Logged In: YES
    user_id=100763

    -----------------------------------------------------
    Now, bring up the DAV server again. Type ls /mnt from root
    you will get an error message "http://old IP address:
    connection refused.

    Basically, the /mnt can not be accessed at all. All the
    mount points under that directory can not be accessed.

     
  • SungHun Kim

    SungHun Kim - 2001-07-03

    Logged In: YES
    user_id=206854

    Hmmm~

    "Just hang" problem is because davfsd still try to connect
    with dav server. After 3 minits it will give you some
    errors like I/O errors or something. Should I make the
    timeout shorter?

    BTW, after restarting dav-server, my davfs works like
    normal.

    Anyway, I'll try it again tomorrow.

    Thanks for your testing and commitment.

     
  • SungHun Kim

    SungHun Kim - 2001-07-03

    Logged In: YES
    user_id=206854

    You were right.

    In davfsd.c, if connect has some problem , it just quit.
    It should give kernel some feed back.

    if(dav_open(&dc, url, id, pass)==NULL) {
    perror(url);
    return 0;
    }

    I'll fix it soon.

    Thanks .

     
  • SungHun Kim

    SungHun Kim - 2001-07-03
    • status: open --> closed
     
  • SungHun Kim

    SungHun Kim - 2001-07-03
    • status: closed --> open
     
  • SungHun Kim

    SungHun Kim - 2001-07-05
    • assigned_to: nobody --> kmkumar
     
  • SungHun Kim

    SungHun Kim - 2001-12-21
    • priority: 9 --> 5
    • status: open --> closed
     

Log in to post a comment.