paper size change not taking

  • jwoo

    jwoo - 2008-01-30

    I need to create a paper size that is huge for a large report.  I create one with this line "paper18=Huge,2000,2000,0.0" and "num_paper_sizes=19".  I do `jar uf ../../lib/DataVision.jar` to add it to the Jar.  I verified that the file is changed there.  When I run the report, I do not see the new paper size.  I have tried changing other sizes, and the changes are not reflected when I run datavision.  I thought it may be something with the runtime environment.  This is in linux, but I have tried in Windows with the same results.  I have also tried updating the language files and specifically running with those languages with no luck.  Any thoughts?


    Jason Woodward

    • Frank W. Zammetti

      It looks like you just made a simple typo: you have a period between the 0's at the end... I copied what you have here exactly, and I saw what you saw, Huge did not show up in the list.  Once I changed that period to a comma though, it worked.

      Hope that helps,

    • jwoo

      jwoo - 2008-01-31

      Oh... that is embarrassing.   Thanks for the response, it is working now.

      • Frank W. Zammetti

        Embarrassing, hehe, I got you beat by a mile... about 20 years ago I spent an ENTIRE WEEKEND debugging a bit of assembly code that just wouldn't work no matter what I did... I finally managed to get it working: I had an ldx token that should have been lxd (or something like that... after 20 years I don't really remember the language, but the point is it was literally two letter flipped around, nothing more).  Compared to that, a period in place of a comma is absolutely nothing to feel bad about! :)


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks