New Module View Settings Problem

  • MercuryCrest

    MercuryCrest - 2011-11-04

    I'm running the latest version (3.9.9) and have run into an odd problem.

    I've created a "Tools" database for the Milwaukee Makerspace to keep track of all of our equipment.

    To this end, I made a brand new module with no predefined fields.  This works fine.  I can now add all of the information that I need, including pictures of the equipment.

    Unfortunately, although everything comes up in Quick View, nothing shows up in Card View.  The items are there, I can click on the blank space and access the item entry, but they don't show up physically as cards.  I can also click on the items and the general area where the picture should be along with the name get highlighted, but this disappears as soon as I do something else.  I should mention that they don't appear in Tile View either.

    I thought that maybe I could adjust something under "View Settings", but that menu won't even come up.  I click on it and nothing happens (the shortcut doesn't work either).  If I click on our "Books" module, everything works just fine.

    I've tried uninstalling and reinstalling.  I've tried backup & restore.  I've even deleted the new module and started over (twice).  I think this may be a problem with the creation of the new module, but I'm not sure what to do.

    And, as long as I'm here, in that same new module, I cannot get rid of a random (not really) string of numbers and letters that display across the top of the items in Quick View.  I've tried adjusting the Quick View Settings, but to no avail.

    Any help is much appreciated.

  • Wheels17

    Wheels17 - 2011-11-08

    I'm laughing as I read your issue, as I'm doing the exact same thing and have the exact same problem.

      I am just starting to play with Data Crow and I'm 99% impressed.  My first custom module is Tool Inventory!!.  My fields are the default ones, plus Description, Model Number, Serial Number, Manufacturer, Number Owned, and Type (Hand or Power) and Picture.   What fields are you using?? I'm sure I'm not thinking of something.

    I have the exact issue with the card view not showing any information.

    The issue exists in some other places as well.  If I quick view on a container that has movies in the container, there is a Movies entry for each movie in the container, but the title of the movie is not displayed.  Books and tools in the box are listed.  If I do a normal view on a container, there's a blank space for the tool that is active if it is clicked, but it does not show anything.

    I suspect that long string is a unique internal database identifier for the system.  It shows up in a few places I was able to eliminate it from the table view by right clicking and removing the Label field.  In the quick view, even if it is unchecked, it is still displayed.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks