SourceForge has been redesigned. Learn more.
Close

#561 Import of Description Field with double-quote (") causes record corruption

3.9.24
closed-accepted
nobody
1
2013-05-12
2013-03-09
Gerald Cox
No

I'm currently migrating from GCSTAR to Datacrow and have some records which have a double-quote (") in the description field. I've found that this causes Datacrow to combine subsequent records. I tested by importing 21 records. With a description which contained (") in some records I ended up with three records which where a mixture of the 21 records which were imported. When I replaced the double quote with a single quote all 21 records were properly imported. For people who are migrating a large collection this is a major problem since a vast majority of their records will be corrupted - and depending on how they validate the import, they might not immediately be aware. The log file shows no errors when this occurs.

Discussion

  • Gerald Cox

    Gerald Cox - 2013-03-11

    I'm attaching a test.csv file. What is happening is that if there is an unmatched " in the description, it appears that datacrow is combining all subsequent records until it finds another ". The test case includes 21 records, but when you import, you will see that only 15 records are created. The problem occurs in the 12th record where I've added a single " in the description. All subsequent records are included in record 12 until the matching " is found 6 records later.

     
  • Gerald Cox

    Gerald Cox - 2013-03-22

    Were you able to recreate this problem? Is there anything else I can do to assist? Please let me know. Thanks!

     
  • Robert Jan van der Waals

    Fixed for the next version.

     
  • Robert Jan van der Waals

    Fixed in 3.9.22

     
  • Robert Jan van der Waals

    • status: open --> closed-fixed
     
  • Gerald Cox

    Gerald Cox - 2013-05-09

    Looks like this isn't fixed in 3.9.24... I didn't try 22 or 23, so perhaps it is a regression. Curiously the problem starts with the movie 2001. The description begins with "2001" at the beginning of the description - but for some reason the first " isn't shown in the description, although it is in the import file. Then that starts the unmatched " issue again. Does your code handle the situation where a double quote starts the description?

     
  • Robert Jan van der Waals

    • status: closed-fixed --> open
     
  • Robert Jan van der Waals

    • Group: 3.9.20 --> 3.9.24
     
  • Gerald Cox

    Gerald Cox - 2013-05-11

    Did some more testing and the problem occurs when the first character of the description field is a double quote. If I add a word in front, i.e. The movie "2001" - it works fine... also if I a set of unmatched quotes - The movie 2001" - it also works fine. So the unmatched quote issue appears fixed. It's a fluke that I start the description field with a double quote... go figure... ;-)

     
  • Robert Jan van der Waals

    Closing this ticket. Thanks for all the information!

    Cheers, Robert

     
  • Robert Jan van der Waals

    • status: open --> closed-accepted
     

Log in to post a comment.