Classic Controller Problem/Bioshock MouseMode

  • Anonymous - 2010-02-15

    So I'm playing Bioshock on my Mac and it's pretty cool. I set up a pretty good control scheme with the classic controller, but it wasn't working right—whenever I press up on the left control stick, it acts like I keep holding it even after letting go, causing my character to keep walking forward. The only way to make him stop is hold down on the control stick, which stops him moving, and doesn't move him back.

    Since I couldn't get that to work, I tried to get a control scheme working with the Wiimote and nunchuck. It was working fine, and all of the controls were great. The nunchuck's control stick didn't have any of the problems the Classic Controller's and worked well. The only problem was that mouse mode stopped working while Bioshock was open! So all of the buttons worked fine but I couldn't move the cursor with the wiimote to look around.

    Does anyone know a fix for either of these problems?

  • Goomba

    Goomba - 2011-05-09

    You're not alone. My left analog stick is doing the same exact thing. I have noticed though when you look at the Hex readout of the directional values of the joysticks, the vertical value on the left stick is almost twice as high as the value on the right stick. I wonder if you could use a program like Max/MSP to intercept the directional value going into DarwiinRemote and subtract/divide to bring it to a normal amount? I'm not really sure, I have zero experience with this. :S

  • Julian Ceipek

    Julian Ceipek - 2011-05-19

    I have the same mouselook problem as CompC; I'm trying to control Portal 2 with the Wiimote and Nunchuck. I successfully modified the code so that the Nunchuck joystick maps to key-presses, but I can't figure out how to control mouselook with the remote. I can successfully use ir mouse control to select items in the game menu, but the moment I enter the game, I cannot use the mouse to control the game character.

    The mouse does not seem to be grabbed properly by the game - I can still move the mouse to trigger the screen corners expose functionality.

    Since I first looked into Objective C's event syntax yesterday, I don't know enough about the problem to fix it.

    Do any of the official devs know what is causing this issue?


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks