Error initializing connection problem

Help
Idan
2011-08-04
2017-01-20
  • Idan

    Idan - 2011-08-04

    I have a problem initializing the connection from eclipse to both clisp and sbcl.  I get the following error message:

    Error initialising connection
    java.net.ConnectException: Connection refused

    I am using ubantu x64

     
  • Marcel

    Marcel - 2011-10-08

    I have a similar problem. If i try to evaluate an expression I get an error: "Error initialising connection
    java.net.ConnectException: Verbindungsaufbau abgelehnt". The Listener shows "disconnected".
    I use OpenSuse 11.4 64bit, Eclipse 3.7.1, Clisp 2.49
    ( I already used the chmod +x - command for setting the permissions )

     
  • Michael Bohn

    Michael Bohn - 2011-10-17

    @marcelb: Can you try to execute the binary in the plugin folder of Eclipse? The path is ./plugins/de.defmacro.env…./binary.
    The Linux versions are only for x86, maybe that's the problem.

     
  • Marcel

    Marcel - 2011-10-18

    @ragnaroek: Thanks for your response.
    I tried to execute the binary and get an error: "error while loading shared libraries: libdb-4.7.so: cannot open shared object file: No such file or directory."
    Any further tip to go on?

     
  • Michael Bohn

    Michael Bohn - 2011-10-18

    You can try to install libdb. Search for db 4.7 in the OpenSuse paket manager.

     
  • Anonymous - 2012-12-24

    Hey there!

    I have the same problem on my mac.

    I installed "de.defmacro.dandelion.env.clisp.mac.intel_2.4.9". I also set the executable flag. But I still get the errors:

    Evaluating:
    Error in background evaluation
    java.net.ConnectException: Connection refused

    Initialising Connection:
    Error initialising connection
    java.net.ConnectException: Connection refused

    Could someone help me with that? I would love to use Eclipse to learn LISP.

    regards,
    Philipp

     
  • Anonymous - 2012-12-24

    By the way: I tried starting the binary with

    philba:binary philba$ ./environment_clisp_2.4.9
    dyld: Library not loaded: /opt/local/lib/libintl.8.dylib
      Referenced from: /Applications/eclipse/plugins/de.defmacro.dandelion.env.clisp.mac.intel_2.4.9/binary/./environment_clisp_2.4.9
      Reason: image not found
    Trace/BPT trap: 5

    But I don't know what that could mean …

     
  • Anonymous - 2012-12-24

    Okay, I got running the SBCL Version on my mac. Should be fine to try out some code snippets for university.

     
  • Michael Bohn

    Michael Bohn - 2012-12-24

    Can you tell me your MacOS-Version? Clisp should be running on your Mac…

     
  • Anonymous - 2013-03-26

    I'm having this problem on OS X 10.8.3.
    First, I had to chmod + x the clisp implementation.
    When I executed this implementation directly, I hit the same error as philwilba with libintl.8.dylib. It appears it's hitting a library dependency that doesn't exist.

    /opt/local/lib/libintl.8.dylib simply doesn't exist on my system.

     
  • Michael Bohn

    Michael Bohn - 2013-03-26

    I will update (at least) the Mac environments this week. They are all a little outdated I guess.

     
  • Anonymous - 2013-03-27

    Awesome! Realistically, all I need is some directions on how to set up a new environment. I noticed the documentation, but I don't speak/read German. I know English, a bit of Latin and French, but not German yet :)

    Would you mind posting some English directions on how to set up a local lisp in the mean time? I'd really be perfectly happy using the system lisp implementation. I just don't know what ports to set, or how to invoke clisp to listen on a port.

     
    • S/A

      S/A - 2013-10-02

      Well, try lispbox. There are older version on the net. Thats pretty easy to run.

       
  • S/A

    S/A - 2013-10-02

    Well, try lispbox. There are older version on the net. Thats pretty easy to run.

     
  • Amir Razmjou

    Amir Razmjou - 2015-08-20

    I managed to solve the problem on Yosemite 10.10.5, run the program directly from /Applications/Eclipse.app/Contents/Eclipse/plugins/de.defmacro.dandelion.env.clisp.mac.intel_2.49.2/binary/environment_clisp_2.49.2 using the terminal and post back the errror messages.

    sudo port install libidl +universal
    sudo ln -s /opt/local/lib/libintl.8.dylib /opt/local/lib/libintl.3.dylib

    solved the problem for me.

     
  • Hygens

    Hygens - 2017-01-20

    On Ubuntu 16.04 or Linux MInt 18 x86_64 or amd64 platforms follow that steps:
    1) Install AptanaStudio3 and Dandelion plugin on it.
    2) On terminal execute:
    sudo dpkg --add-architecture i386 && sudo apt-get update
    3) On Terminal in folder .../Aptana_Studio_3/plugins/de.defmacro.dandelion.env.clisp.linux.x86_2.49.2/binary/ execute:
    chmod u+x environment_clisp_2.49.2
    4) Install sudo apt-fast install -y libreadline5:i386
    5) Install sudo apt-fast install -y libidl-2-0:i386 libidl-dev:i386 libidl-common:i386
    6) Install sudo apt-fast install -y clisp:i386.
    7) Execute AptanaStudio3, configure your environment, create one projet on Lisp perspective.
    8) On image for more better executions I have configurec environment that form showed on image attached.
    9) Voàlla!!! Functioning 100% with all resources need for any projet(web, desktop or mobile) in unique local because AptanaStudio3 have facilities for that.

     
    Last edit: Hygens 2017-01-20

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks