java.rmi.RemoteException - Connection refused

fa74
2005-04-28
2013-04-22
  • fa74

    fa74 - 2005-04-28

    Hi,

    We're trying to install Daffodil Replicator. We are usign:

    - Fedora Core 3
    - J2SDK 1.4.1_07
    - PostgreSQL 7.3
    - Daffodil Replicator 1.7

    We install and run the Publication Server in one host and create a new publication (with success). We then install and run de Subcription Server on a different host. When we try to create a subscription, we get an error, both in the publication server and in the subscription server: java.rmi.RemoteException - Connection refused.

    Any ideas?

    Thanks in advance.

     
    • subesingh

      subesingh - 2005-05-04

      Hi,

          Daffodil Replication Server is not getting connection from remote machine where Publication Server is Running.

           Plz check IP address of reomte machine that you have used when try to create subscription.

      Thanks and Regards,
      Sube Singh

       
      • fa74

        fa74 - 2005-05-04

        Hi,

        Thanks for the response, but I think that's not the problem. As you can see, the request gets to the publisher server, as the messages it logs to the ERROR.log file are written when the subscriber tries to make the subscription.

        On the other hand, from the subscriber we open a telnet session to the IP/port where the publisher server is running, and everything is OK. From the publisher we open a telnet session to the IP/port where the subscription server is running, and everything is OK.

        It seems to be a permissions problem, o something like that. Does daffodil have any restriction? Any other idea of where can be the problem?

        Thanks.

         
    • psicolor

      psicolor - 2005-06-24

      Hi,

      I have exactly the same issues, but i couldn't find out more than vaalva74...

      Are there any news regarding this problem?

      Bye

       
    • subesingh

      subesingh - 2005-06-30

      It seems that problem is due to setting of configuration file in postgreSQL database.So make the following chages:

      Change the file postgresql.conf by uncommenting the default settings of tcpip_socket  as :
      ...
      #
      #       Connection Parameters
      #
      tcpip_socket = true
      #ssl = false
      ...

      Now allow access to the server by TCP/IP. Open the file pg_hba.conf in the same directory as above and add at the end the following line.

      local
      ...
      host    all         all         127.0.0.1         255.255.255.255    trust

      Sube Singh

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks