I am sorry to mistake libexpat to libexpat

Help
2006-11-30
2013-04-25
  • Nobody/Anonymous

    At first,I must make appologize to you in that I mistaked "libexpat.so"
    to "libexpat.so" which might make you very confuse.And I didn't paste
    my full text at last time .At this time,my full text show as following:

    Thank you very much for your last helping.
    For your suggest,I create a file ".defaults.in"and
    Paste the following text into this file。
       
        Default_owner="@nobody@"
        Default_group="@www@"

    When I run the following command,it's ok.
      
       ./configure --prefix=/usr/local/dacs --disable-shared \     --enable-static --enable-passwd-auth \     --disable-bdb --with-apache=/usr/local/apache-dacs \     --with-expat=/usr/local
        gmake

    But continue to run “gmake install”,an error occured :
       
       --------
        ./version: error while loading shared libraries: libexpat.so.1:cannot open
             shared object file:Nosuch file or directory.
       NOTES:
       */usr/local/apache-dacs/cgi-bin/dacs/local_unix_authenticate may need to be
        setuid or setgid in order to check passwords:
           chown roots /usr/local/apache-dacs/cgi-bin/dacs/local_unix_authenticate
           chown u+s /usr/local/apache-dacs/cgi-bin/dacs/local_unix_authenticate
       *Run 'make install-autologin' if you require autologin
       *Check that /usr/local/dacs-11/man is on your MANPATH
       *DACS version info:

    And I continue to Step 4: DACS-enable Apache
    When I start Apache again
    I can open " http://dodgers.dacstest.dss.ca:18123/man "
    but can't open " http://dodgers.dacstest.dss.ca:18123/cgi-bin/dacs/prenv ".
    I don't know what's wrong.

    I go to do Step 5: Do basic DACS configuration .
    There is no problem befor I run the following command:

            $bin/conf -u dodgers.dacstest.dss.ca -q

    The system output :

    /usr/local/dacs/bin/conf:error while loading shared libraries: libexpat.so.1:
    cannot open share object file: No such file or directory

    this problem is the same as the first one(gmake install).
    So I realized that I haven't finish install DACS.
    I don't know why this error occured and what can I do to solve this problem.
    I need your help and thanks again!

     
    • Barry Brachman

      Barry Brachman - 2006-11-30

      > ./version: error while loading shared libraries:
      > libexpat.so.1:cannot open
      > shared object file:Nosuch file or directory.

      You may need to add /usr/local/expat/lib to the paths
      used by ldconfig (On Solaris, crle).
      Check your manual page, but you might try something
      like (as root): ldconfig -m /usr/local/expat/lib
      If that solves the problem, you will need to do that
      after every system reboot.

      I believe the next release of DACS, which is due within
      a few days, will fix this problem for you.

      Barry

       

Log in to post a comment.