#2606 1.16.1 Mac - per pixel not working in 64 bit mode

Mac_OS_X_(Intel)
open
nobody
Graphics (494)
5
2013-02-19
2012-04-30
Darklord42
No

As the description says for some reason per pixel doesn\'t work in 64 bit mode. Does work in 32 bit mode just fine. (To enable right click on d2x-xl.app and select \"get info\" then check \"Open in 32 bit mode\" if anyone wants to try that)

when in 64 what displays is part of the render and the rest is black. If you move the other half appears and the first half goes black.

Discussion

  • Darklord42

    Darklord42 - 2012-04-30
     
    Attachments
  • Darklord42

    Darklord42 - 2012-04-30

    Well it might not be the compiler. I tried switching from the Apple LLVM 3.1 to the older gcc 4.2 which built successfully and had the same issue. worth a shot though ;)

    Still how does this behave in a windows compile of 64 bit? I don't have a 64 bit windows OS to try it.

     
  • Darklord42

    Darklord42 - 2013-01-21

    d2x.log

     
    Attachments
  • Darklord42

    Darklord42 - 2013-01-21

    Naturally still in .16 Not sure why i didn't do this before but d2x.log spewed out a bunch of stuff on the calculation attempt that may be worth looking at. Apperently something isn't quite right with the way it's being compiled in 64 bit. Is this not an issue in windows?

     
  • Darklord42

    Darklord42 - 2013-01-23

    I have long since realized that this issue is with lightmaps in general, not per pixel aspect.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks