cygwin-ports-general-request@lists.sourceforge.net wrote:
Message: 2
Date: Tue, 04 Sep 2007 22:23:14 -0500
From: "Yaakov (Cygwin Ports)" <yselkowitz@users.sourceforge.net>
Subject: Re: [Cygwin-ports-general] setup.ini missing from Ports
To: cygwin-ports-general@lists.sourceforge.net
Message-ID: <46DE2122.3060607@users.sourceforge.net>
Content-Type: text/plain; charset=ISO-8859-1

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Doug Younkin wrote:
  
Not a connection problem.  Anonymous ftp even shows NO setup.ini.  See
below.
    

The file is called setup.bz2 on the server, and setup.exe knows what to
do with it.

  
Well problem solved, though I am guessing what happened.  I had been using the current setup.exe from http://www.cygwin.com (which is version 2.573.2.2).  It would download setup.bz2 and then report an error about not finding setup.ini when trying to connect with ftp://sunsite.dk/projects/cygwinports/.  The other cygwin mirror I tried with the newest setup.exe have both setup.bz2 and setup.ini.  I have had no problems downloading from the cygwin mirror at http://mirror.calvin.edu/cygwin.

However, then I used the older setup.exe (version 2.510.2.2) from the Ports mirror.  It only looked for the setup.bz2 file to download, then proceeded fine to the list of packages to download.  Then I exited the older setup.exe, ran the newer setup.exe again and this time it worked. 

My guess is that the older setup.exe managed to download setup.bz2 and extract setup.ini from it and dump it into the local mirror directory.  Then the newer setup.exe could find setup.ini for Ports and though it complained about the datestamp, it did go on to the package list.

Now at least I can download Ports packages and will use the workaround with the sed script operating on setup.ini timestamp.

By the way, I have an automated cygwin updater script, but it relies on command line options that aren't available in the older setup.exe you have on Ports.  Using this older version of setup.exe also complains twice (once that setup.exe is out of date and again that setup.ini is out of date), requiring user interaction.  My script doesn't deal with user interaction requirements.  I will be trying out my scripts with Ports and see what kind of compatibility adjustments I need to make.

Doug Younkin