gnome-session pop up window errors on startup

Help
slink44
2005-02-02
2013-06-05
  • slink44

    slink44 - 2005-02-02

    This is my xinitrc
    ------------------
    #!/bin/sh
    # $Xorg: xinitrc.cpp,v 1.3 2000/08/17 19:54:30 cpqbld Exp $

    userresources="$HOME"/.Xresources
    usermodmap="$HOME"/.Xmodmap
    sysresources=/usr/X11R6/lib/X11/xinit/.Xresources
    sysmodmap=/usr/X11R6/lib/X11/xinit/.Xmodmap

    # merge in defaults and keymaps

    if [ -f $sysresources ]; then
        xrdb -merge $sysresources
    fi

    if [ -f $sysmodmap ]; then
        xmodmap $sysmodmap
    fi

    if [ -f $userresources ]; then
        xrdb -merge $userresources
    fi

    if [ -f $usermodmap ]; then
        xmodmap $usermodmap
    fi

    # start some nice programs

    #exec xterm -sl 1000 -sb -rightbar -ms red -fg yellow -bg black -e /usr/bin/bash -l
    exec /opt/gnome2/bin/gnome-session

    ----------------------------------------
    this is the error i get when i startx
    -----------------------------------------
    Saul7335@330W34MZJ015 /cygdrive/c/DOCUME~1/Saul7335/LOCALS~1/Temp
    $ startx&
    [1] 1768

    Saul7335@330W34MZJ015 /cygdrive/c/DOCUME~1/Saul7335/LOCALS~1/Temp
    $
    Welcome to the XWin X Server
    Vendor: The Cygwin/X Project
    Release: 6.8.1.0-9

    Contact: cygwin-xfree@cygwin.com

    XWin was started with the following command line:

    X :0 -multiwindow -clipboard

    _XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
    winValidateArgs - g_iNumScreens: 1 iMaxConsecutiveScreen: 1
    (II) XF86Config is not supported
    (II) See http://x.cygwin.com/docs/faq/cygwin-x-faq.html for more information
    (==) FontPath set to "/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/TT
    F/,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/CID/,/usr/X11R6/lib/
    X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/"
    winDetectSupportedEngines - Windows NT/2000/XP
    winDetectSupportedEngines - DirectDraw installed
    winDetectSupportedEngines - DirectDraw4 installed
    winDetectSupportedEngines - Returning, supported engines 00000007
    winSetEngine - Multi Window or Rootless => ShadowGDI
    winAdjustVideoModeShadowGDI - Using Windows display depth of 32 bits per pixel
    winAllocateFBShadowGDI - Creating DIB with width: 1024 height: 768 depth: 32
    winFinishScreenInitFB - Masks: 00ff0000 0000ff00 000000ff
    winInitVisualsShadowGDI - Masks 00ff0000 0000ff00 000000ff BPRGB 8 d 24 bpp 32
    null screen fn ReparentWindow
    null screen fn RestackWindow
    InitQueue - Calling pthread_mutex_init
    InitQueue - pthread_mutex_init returned
    InitQueue - Calling pthread_cond_init
    InitQueue - pthread_cond_init returned
    winInitMultiWindowWM - Hello
    winInitMultiWindowWM - Calling pthread_mutex_lock ()
    winMultiWindowXMsgProc - Hello
    winMultiWindowXMsgProc - Calling pthread_mutex_lock ()
    MIT-SHM extension disabled due to lack of kernel support
    XFree86-Bigfont extension local-client optimization disabled due to lack of shar
    ed memory support in the kernel
    (--) Setting autorepeat to delay=500, rate=31
    (--) winConfigKeyboard - Layout: "00000409" (00000409)
    (--) Using preset keyboard for "English (USA)" (409), type "4"
    Rules = "xorg" Model = "pc105" Layout = "us" Variant = "(null)" Options = "(null
    )"
    (--) 3 mouse buttons found
    Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from li
    st!
    winPointerWarpCursor - Discarding first warp: 512 384
    winInitMultiWindowWM - pthread_mutex_lock () returned.
    winMultiWindowXMsgProc - pthread_mutex_lock () returned.
    winInitMultiWindowWM - pthread_mutex_unlock () returned.
    winMultiWindowXMsgProc - pthread_mutex_unlock () returned.
    winMultiWindowXMsgProc - DISPLAY=127.0.0.1:0.0
    winInitMultiWindowWM - DISPLAY=127.0.0.1:0.0
    winProcEstablishConnection - Hello
    cat: /cygdrive/c/Documents and Settings/Saul7335/.Xauthority: No such file or di
    rectory
    winInitClipboard ()
    winProcEstablishConnection - winInitClipboard returned.
    winClipboardProc - Hello
    DetectUnicodeSupport - Windows NT/2000/XP
    winClipboardProc - DISPLAY=127.0.0.1:0.0
    winMultiWindowXMsgProc - XOpenDisplay () returned and successfully opened the di
    splay.
    winInitMultiWindowWM - XOpenDisplay () returned and successfully opened the disp
    lay.
    winClipboardProc - XOpenDisplay () returned and successfully opened the display.

    winProcSetSelectionOwner - Clipboard not yet started, aborting.
    winProcSetSelectionOwner - Clipboard not yet started, aborting.
    [: and: unknown operand
    [: and: unknown operand

    Saul7335@330W34MZJ015 /cygdrive/c/DOCUME~1/Saul7335/LOCALS~1/Temp
    $

    Saul7335@330W34MZJ015 /cygdrive/c/DOCUME~1/Saul7335/LOCALS~1/Temp
    $ Failed to run gconf-sanity-check-2: Failed to execute child process "/opt/gnom
    e2/libexec/gconf-sanity-check-2" (No such file or directory)
    _IceTransmkdir: Owner of /tmp/.ICE-unix should be set to root
    SESSION_MANAGER=local/330W34MZJ015:/tmp/.ICE-unix/1344

    (gnome-session:1344): GdkPixbuf-WARNING **: Can not open pixbuf loader module fi
    le '/opt/gnome2/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory

    (gnome-session:1344): GdkPixbuf-WARNING **: Can not open pixbuf loader module fi
    le '/opt/gnome2/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory

    (gnome-session:1344): GdkPixbuf-WARNING **: Can not open pixbuf loader module fi
    le '/opt/gnome2/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory

    (gnome-session:1344): GdkPixbuf-WARNING **: Can not open pixbuf loader module fi
    le '/opt/gnome2/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory

    (gnome-session:1344): GdkPixbuf-WARNING **: Can not open pixbuf loader module fi
    le '/opt/gnome2/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory

    (gnome-session:1344): GdkPixbuf-WARNING **: Can not open pixbuf loader module fi
    le '/opt/gnome2/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory

    (gnome-session:1344): Gdk-CRITICAL **: file gdkdraw.c: line 651 (gdk_draw_drawab
    le): assertion `src != NULL' failed

    (gnome-session:1344): GdkPixbuf-WARNING **: Can not open pixbuf loader module fi
    le '/opt/gnome2/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory

    (gnome-session:1344): GdkPixbuf-WARNING **: Can not open pixbuf loader module fi
    le '/opt/gnome2/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory

    (gnome-session:1344): GdkPixbuf-WARNING **: Can not open pixbuf loader module fi
    le '/opt/gnome2/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory

    (gnome-session:1344): Gdk-CRITICAL **: file gdkdraw.c: line 651 (gdk_draw_drawab
    le): assertion `src != NULL' failed
    Error setting value: No database available to save your configuration: Unable to
    store a value at key '/desktop/gnome/applications/window_manager/default', as t
    he configuration server has no writable databases. There are some common causes
    of this problem: 1) your configuration path file /etc/gconf/2/path doesn't conta
    in any databases or wasn't found 2) somehow we mistakenly created two gconfd pro
    cesses 3) your operating system is misconfigured so NFS file locking doesn't wor
    k in your home directory or 4) your NFS client machine crashed and didn't proper
    ly notify the server on reboot that file locks should be dropped. If you have tw
    o gconfd processes (or had two at the time the second was launched), logging out
    , killing all copies of gconfd, and logging back in may help. If you have stale
    locks, remove ~/.gconf*/*lock. Perhaps the problem is that you attempted to use
    GConf from two machines at once, and ORBit still has its default configuration t
    hat prevents remote CORBA connections - put "ORBIIOPIPv4=1" in /etc/orbitrc. As
    always, check the user.* syslog for details on problems gconfd encountered. Ther
    e can only be one gconfd per home directory, and it must own a lockfile in ~/.gc
    onfd and also lockfiles in individual storage locations such as ~/.gconf

    (gnome-session:1344): GdkPixbuf-WARNING **: Can not open pixbuf loader module fi
    le '/opt/gnome2/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory
    Window manager warning: 0 stored in GConf key /apps/metacity/general/num_workspa
    ces is not a reasonable number of workspaces, current maximum is 36

    (gnome-session:1344): Gdk-CRITICAL **: file gdkdraw.c: line 651 (gdk_draw_drawab
    le): assertion `src != NULL' failed

    (gnome-session:1344): GdkPixbuf-WARNING **: Can not open pixbuf loader module fi
    le '/opt/gnome2/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory

    (gnome-session:1344): GdkPixbuf-WARNING **: Can not open pixbuf loader module fi
    le '/opt/gnome2/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory

    (gnome-session:1344): GdkPixbuf-WARNING **: Can not open pixbuf loader module fi
    le '/opt/gnome2/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory

    (gnome-session:1344): GdkPixbuf-WARNING **: Can not open pixbuf loader module fi
    le '/opt/gnome2/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory

    (gnome-session:1344): GdkPixbuf-WARNING **: Can not open pixbuf loader module fi
    le '/opt/gnome2/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory

    (gnome-session:1344): GdkPixbuf-WARNING **: Can not open pixbuf loader module fi
    le '/opt/gnome2/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory

    (gnome-session:1344): GdkPixbuf-WARNING **: Can not open pixbuf loader module fi
    le '/opt/gnome2/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory

    (gnome-session:1344): Gdk-CRITICAL **: file gdkdraw.c: line 651 (gdk_draw_drawab
    le): assertion `src != NULL' failed

    (gnome-panel:2064): Gtk-WARNING **: Ignoring the separator setting

    (gnome-panel:2064): GdkPixbuf-WARNING **: Can not open pixbuf loader module file
    '/opt/gnome2/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory

    (gnome-session:1344): Gdk-CRITICAL **: file gdkdraw.c: line 651 (gdk_draw_drawab
    le): assertion `src != NULL' failed

    (gnome-session:1344): Gdk-CRITICAL **: file gdkdraw.c: line 651 (gdk_draw_drawab
    le): assertion `src != NULL' failed

    (nautilus:2092): Eel-WARNING **: GConf error:
      No database available to save your configuration: Unable to store a value at k
    ey '/apps/nautilus/preferences_version', as the configuration server has no writ
    able databases. There are some common causes of this problem: 1) your configurat
    ion path file /etc/gconf/2/path doesn't contain any databases or wasn't found 2)
    somehow we mistakenly created two gconfd processes 3) your operating system is
    misconfigured so NFS file locking doesn't work in your home directory or 4) your
    NFS client machine crashed and didn't properly notify the server on reboot that
    file locks should be dropped. If you have two gconfd processes (or had two at t
    he time the second was launched), logging out, killing all copies of gconfd, and
    logging back in may help. If you have stale locks, remove ~/.gconf*/*lock. Perh
    aps the problem is that you attempted to use GConf from two machines at once, an
    d ORBit still has its default configuration that prevents remote CORBA connectio
    ns - put "ORBIIOPIPv4=1" in /etc/orbitrc. As always, check the user.* syslog for
    details on problems gconfd encountered. There can only be one gconfd per home d
    irectory, and it must own a lockfile in ~/.gconfd and also lockfiles in individu
    al storage locations such as ~/.gconf

    (nautilus:2092): GdkPixbuf-WARNING **: Can not open pixbuf loader module file '/
    opt/gnome2/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory
    /bin/cp: `Settings/Saul7335/Desktop/starthere.desktop': specified destination di
    rectory does not exist
    Try `/bin/cp --help' for more information.

    ** (nautilus:2092): WARNING **: Failed to execute command '/bin/cp /opt/gnome2/s
    hare/nautilus/starthere-link.desktop /cygdrive/c/Documents and Settings/Saul7335
    /Desktop/starthere.desktop'

    after all of this i get 4 error (pop up windows from Xwin or GNOME, i am not sure? i think gnome) boxes that pop up telling me
    first one
    ---------
    There was an error starting the GNOME Settings Daemon.

    Some things, such as themes, sounds, or background settings may not work correctly.

    The Settings Daemon restarted too many times.

    The last error message was:

    Failed to activate 'OAFIID:GNOME_SettingsDaemon'

    GNOME will still try to restart the Settings Daemon next time you log in.
    ----------------------------

    second one
    ------------
    There was a problem registering the panel with the bonobo-activation server.
    The error code is: 1
    The panel will now exit.
    ------------------------
    third one (it is a GConf error)
    ----------
    GConf error:
      No database available to save your configuration: Unable to store a value at key '/apps/nautilus/preferences_version', as the configuration server has no writable databases. There are some common causes of this problem: 1) your configuration path file /etc/gconf/2/path doesn't contain any databases or wasn't found 2) somehow we mistakenly created two gconfd processes 3) your operating system is misconfigured so NFS file locking doesn't work in your home directory or 4) your NFS client machine crashed and didn't properly notify the server on reboot that file locks should be dropped. If you have two gconfd processes (or had two at the time the second was launched), logging out, killing all copies of gconfd, and logging back in may help. If you have stale locks, remove ~/.gconf*/*lock. Perhaps the problem is that you attempted to use GConf from two machines at once, and ORBit still has its default configuration that prevents remote CORBA connections - put "ORBIIOPIPv4=1" in /etc/orbitrc. As always, check the user.* syslog for details on problems gconfd encountered. There can only be one gconfd per home directory, and it must own a lockfile in ~/.gconfd and also lockfiles in individual storage locations such as ~/.gconf
    All further errors shown only on terminal
    ----------------------------------------------
    the fourth and last one
    -----------------------
    Nautilus can't be used now. Running the command "bonobo-slay" from the console may fix the problem. If not, you can try rebooting the computer or installing Nautilus again.

    Bonobo couldn't locate the Nautilus_shell.server file. One cause of this seems to be an LD_LIBRARY_PATH that does not include the bonobo-activation library's directory. Another possible cause would be bad install with a missing Nautilus_Shell.server file.

    Running "bonobo-slay" will kill all Bonobo Activation and GConf processes, which may be needed by other applications.

    Sometimes killing bonobo-activation-server and gconfd fixes the problem, but we don't know why.

    We have also seen this error when a faulty version of bonobo-activation was installed.
    ------------------------------------------------

    if any one can help it would be great.  i did the whole un lock gconf and orbit.
    (http://article.gmane.org/gmane.os.cygwin.cygnome2.devel/9)

    if anybody sees something that i am not seeing, let me know.

    thanks.

     
    • slink44

      slink44 - 2005-02-03

      ok i deleted conflicting gtk libraries
      ---------------------------------
      412  rm /opt/gnome2/bin/cyggdk*.dll
      413  rm /opt/gnome2/bin/cyggtk-x11*.dll)
      ---------------------------------
      and now the GNOME 2.4 screen pops up and the modules start to load until i think the WindowManager.  Then the an error pop up window gives the error message.

      then this error comes up
      --------------------------
      There was an error starting the GNOME Settings Daemon.

      Some things, such as themes, sounds, or background settings may not work correctly.

      The Settings Daemon restarted too many times.

      The last error message was:

      Failed to activate 'OAFIID:GNOME_SettingsDaemon'

      GNOME will still try to restart the Settings Daemon next time you log in.
      --------------------------------------------------

      the console output is as followed

      --------------------------------------------------

      Saul7335@330W34MZJ015 ~
      $ startx

      Welcome to the XWin X Server
      Vendor: The Cygwin/X Project
      Release: 6.8.1.0-9

      Contact: cygwin-xfree@cygwin.com

      XWin was started with the following command line:

      X :0 -multiwindow -clipboard

      _XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
      winValidateArgs - g_iNumScreens: 1 iMaxConsecutiveScreen: 1
      (II) XF86Config is not supported
      (II) See http://x.cygwin.com/docs/faq/cygwin-x-faq.html for more information
      (==) FontPath set to "/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/TT
      F/,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/CID/,/usr/X11R6/lib/
      X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/"
      winDetectSupportedEngines - Windows NT/2000/XP
      winDetectSupportedEngines - DirectDraw installed
      winDetectSupportedEngines - DirectDraw4 installed
      winDetectSupportedEngines - Returning, supported engines 00000007
      winSetEngine - Multi Window or Rootless => ShadowGDI
      winAdjustVideoModeShadowGDI - Using Windows display depth of 32 bits per pixel
      winAllocateFBShadowGDI - Creating DIB with width: 1024 height: 768 depth: 32
      winFinishScreenInitFB - Masks: 00ff0000 0000ff00 000000ff
      winInitVisualsShadowGDI - Masks 00ff0000 0000ff00 000000ff BPRGB 8 d 24 bpp 32
      null screen fn ReparentWindow
      null screen fn RestackWindow
      InitQueue - Calling pthread_mutex_init
      InitQueue - pthread_mutex_init returned
      InitQueue - Calling pthread_cond_init
      InitQueue - pthread_cond_init returned
      winInitMultiWindowWM - Hello
      winInitMultiWindowWM - Calling pthread_mutex_lock ()
      winMultiWindowXMsgProc - Hello
      winMultiWindowXMsgProc - Calling pthread_mutex_lock ()
      MIT-SHM extension disabled due to lack of kernel support
      XFree86-Bigfont extension local-client optimization disabled due to lack of shar
      ed memory support in the kernel
      (--) Setting autorepeat to delay=500, rate=31
      (--) winConfigKeyboard - Layout: "00000409" (00000409)
      (--) Using preset keyboard for "English (USA)" (409), type "4"
      Rules = "xorg" Model = "pc105" Layout = "us" Variant = "(null)" Options = "(null
      )"
      (--) 3 mouse buttons found
      Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from li
      st!
      winPointerWarpCursor - Discarding first warp: 512 384
      winInitMultiWindowWM - pthread_mutex_lock () returned.
      winMultiWindowXMsgProc - pthread_mutex_lock () returned.
      winInitMultiWindowWM - pthread_mutex_unlock () returned.
      winMultiWindowXMsgProc - pthread_mutex_unlock () returned.
      winMultiWindowXMsgProc - DISPLAY=127.0.0.1:0.0
      winInitMultiWindowWM - DISPLAY=127.0.0.1:0.0
      winProcEstablishConnection - Hello
      cat: /cygdrive/c/Documents and Settings/Saul7335/.Xauthority: No such file or di
      rectory
      winInitClipboard ()
      winProcEstablishConnection - winInitClipboard returned.
      winClipboardProc - Hello
      DetectUnicodeSupport - Windows NT/2000/XP
      winClipboardProc - DISPLAY=127.0.0.1:0.0
      winMultiWindowXMsgProc - XOpenDisplay () returned and successfully opened the di
      splay.
      winInitMultiWindowWM - XOpenDisplay () returned and successfully opened the disp
      lay.
      winClipboardProc - XOpenDisplay () returned and successfully opened the display.

      [: and: unknown operand
      [: and: unknown operand
      Failed to run gconf-sanity-check-2: Failed to execute child process "/opt/gnome2
      /libexec/gconf-sanity-check-2" (No such file or directory)
      _IceTransmkdir: Owner of /tmp/.ICE-unix should be set to root
      SESSION_MANAGER=local/330W34MZJ015:/tmp/.ICE-unix/1608
      Gnome-Message: gnome_execute_async_with_env_fds: returning -1
      Gnome-Message: gnome_execute_async_with_env_fds: returning -1
      Gnome-Message: gnome_execute_async_with_env_fds: returning -1
      Gnome-Message: gnome_execute_async_with_env_fds: returning -1
      --------------------------------------------------

      again, any help would be appreciated.

      -thanks

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks