gtk-config problem

Help
Axel R.
2003-09-26
2003-12-08
  • Axel R.

    Axel R. - 2003-09-26

    Hi all,
    I try to compile a program (http://www.grisbi.org) and when the ./configure etape, I've this problem :

    I've got now this message :

    checking for GTK - version >= 1.2.0... no
    *** Could not run GTK test program, checking why...
    *** The test program failed to compile or link. See the file config.log for the
    *** exact error that occured. This usually means GTK was incorrectly installed
    *** or that you have moved GTK since it was installed. In the latter case, you
    *** may want to edit the gtk-config script: /opt/gnome/bin/gtk-config
    configure: error: GTK not installed
    ./configure: line 7281: exit: or: numeric argument required
    ./configure: line 7281: exit: or: numeric argument required

    but when I launch the gtk-config program :

    $ gtk-config --version
    1.2.10

    What's happen ?

    Thank for your help,

    Axel

     
    • Yang Guilong

      Yang Guilong - 2003-09-26

      Whick version of grisbi are you tring to compile?
      Version 0.4.1 compiles smoothly on my installation.

      Or could you send me the config.log you got and let me have a look?
      As it reads above: "See the file config.log for the exact error that occured"

       
    • Terrot Francois

      Terrot Francois - 2003-12-08

      Hi
      As I also had the problem.
      I looked in the config.log.
      The problem is due to cygwin library location.
      The X11R6 library are located in /usr/X11R6/bin , and not in /usr/X11R6/lib.
      So the solution is to add /usr/X11R6/bin in your LIBRARY_PATH variable
      Regards
      Francois

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks